summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-compose/files/docker-compose-1.27.0_rc3-setup-py.patch')
-rw-r--r--app-emulation/docker-compose/files/docker-compose-1.27.0_rc3-setup-py.patch67
1 files changed, 0 insertions, 67 deletions
diff --git a/app-emulation/docker-compose/files/docker-compose-1.27.0_rc3-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.27.0_rc3-setup-py.patch
deleted file mode 100644
index 3026933addd2..000000000000
--- a/app-emulation/docker-compose/files/docker-compose-1.27.0_rc3-setup-py.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 3b4800ed5b24cea7af00aa868964e3d46e81364e Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Thu, 3 Sep 2020 19:59:36 +0200
-Subject: [PATCH] setup.py: Drop generic upper version boundaries
-
----
- setup.py | 34 +++++++++++++++++-----------------
- 1 file changed, 17 insertions(+), 17 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index e0d4340..648a736 100644
---- a/setup.py
-+++ b/setup.py
-@@ -25,33 +25,33 @@ def find_version(*file_paths):
-
-
- install_requires = [
-- 'cached-property >= 1.2.0, < 2',
-- 'docopt >= 0.6.1, < 1',
-- 'PyYAML >= 3.10, < 6',
-- 'requests >= 2.20.0, < 3',
-- 'texttable >= 0.9.0, < 2',
-- 'websocket-client >= 0.32.0, < 1',
-- 'distro >= 1.5.0, < 2',
-- 'docker[ssh] >= 4.3.1, < 5',
-- 'dockerpty >= 0.4.1, < 1',
-- 'jsonschema >= 2.5.1, < 4',
-- 'python-dotenv >= 0.13.0, < 1',
-+ 'cached-property >= 1.2.0',
-+ 'docopt >= 0.6.1',
-+ 'PyYAML >= 3.10',
-+ 'requests >= 2.20.0',
-+ 'texttable >= 0.9.0',
-+ 'websocket-client >= 0.32.0',
-+ 'distro >= 1.5.0',
-+ 'docker[ssh] >= 4.3.1',
-+ 'dockerpty >= 0.4.1',
-+ 'jsonschema >= 2.5.1',
-+ 'python-dotenv >= 0.13.0',
- ]
-
-
- tests_require = [
-- 'ddt >= 1.2.2, < 2',
-- 'pytest < 6',
-+ 'ddt >= 1.2.2',
-+ 'pytest',
- ]
-
-
- if sys.version_info[:2] < (3, 4):
-- tests_require.append('mock >= 1.0.1, < 4')
-+ tests_require.append('mock >= 1.0.1')
-
- extras_require = {
-- ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5, < 4'],
-- ':sys_platform == "win32"': ['colorama >= 0.4, < 1'],
-- 'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
-+ ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
-+ ':sys_platform == "win32"': ['colorama >= 0.4'],
-+ 'socks': ['PySocks >= 1.5.6, != 1.5.7'],
- 'tests': tests_require,
- }
-
---
-2.27.0
-