summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild')
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild
new file mode 100644
index 000000000000..49cfe2508b71
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ >=sys-apps/coreutils-6.10-r1
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}