summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libguestfs/files/1.26')
-rw-r--r--app-emulation/libguestfs/files/1.26/0000_bug_499150.patch10
-rw-r--r--app-emulation/libguestfs/files/1.26/0001_add_gentoo_names_to_configure.patch15
-rw-r--r--app-emulation/libguestfs/files/1.26/0002_add_gentooway_to_remove_la_files.patch16
-rw-r--r--app-emulation/libguestfs/files/1.26/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch21
-rw-r--r--app-emulation/libguestfs/files/1.26/0020_all_qemu_configure.patch27
-rw-r--r--app-emulation/libguestfs/files/1.26/0103_disable_php_bindings_makefile.patch13
6 files changed, 102 insertions, 0 deletions
diff --git a/app-emulation/libguestfs/files/1.26/0000_bug_499150.patch b/app-emulation/libguestfs/files/1.26/0000_bug_499150.patch
new file mode 100644
index 000000000000..1e0f1a32185e
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.26/0000_bug_499150.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac 2014-01-24 19:04:05.633056872 +0100
++++ b/configure.ac 2014-01-24 19:04:34.685691757 +0100
+@@ -24,6 +24,7 @@
+
+ AC_INIT([libguestfs],libguestfs_major.libguestfs_minor.libguestfs_release)
+ AC_CONFIG_AUX_DIR([build-aux])
++AM_GNU_GETTEXT_VERSION(0.18.3)
+
+ dnl Initialize automake. automake < 1.12 didn't have serial-tests and
+ dnl gives an error if it sees this, but for automake >= 1.13
diff --git a/app-emulation/libguestfs/files/1.26/0001_add_gentoo_names_to_configure.patch b/app-emulation/libguestfs/files/1.26/0001_add_gentoo_names_to_configure.patch
new file mode 100644
index 000000000000..9d209ff53584
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.26/0001_add_gentoo_names_to_configure.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -482,6 +482,11 @@
+ DISTRO=UBUNTU
+ fi
+ fi
++
++if test -f /etc/gentoo-release; then
++ DISTRO=GENTOO
++fi
++
+ if test -f /etc/arch-release; then
+ DISTRO=ARCHLINUX
+ fi
diff --git a/app-emulation/libguestfs/files/1.26/0002_add_gentooway_to_remove_la_files.patch b/app-emulation/libguestfs/files/1.26/0002_add_gentooway_to_remove_la_files.patch
new file mode 100644
index 000000000000..38a591b811ed
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.26/0002_add_gentooway_to_remove_la_files.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1487,8 +1487,10 @@
+
+ dnl Replace libtool with a wrapper that clobbers dependency_libs in *.la files
+ dnl http://lists.fedoraproject.org/pipermail/devel/2010-November/146343.html
+-LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
+-AC_SUBST([LIBTOOL])
++dnl LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
++dnl AC_SUBST([LIBTOOL])
++LT_INIT
++
+
+ dnl Produce output files.
+ AC_CONFIG_HEADERS([config.h])
diff --git a/app-emulation/libguestfs/files/1.26/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch b/app-emulation/libguestfs/files/1.26/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch
new file mode 100644
index 000000000000..69b3ae6d0d2d
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.26/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch
@@ -0,0 +1,21 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1491,11 +1491,12 @@
+ ])
+
+ # check for gtk-doc
+-m4_ifdef([GTK_DOC_CHECK], [
+- GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+-],[
+- AM_CONDITIONAL([ENABLE_GTK_DOC], false)
+-])
++#m4_ifdef([GTK_DOC_CHECK], [
++# GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
++#],[
++# AM_CONDITIONAL([ENABLE_GTK_DOC], false)
++#])
++GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+
+ dnl Library versioning.
+ MAX_PROC_NR=`cat $srcdir/src/MAX_PROC_NR`
diff --git a/app-emulation/libguestfs/files/1.26/0020_all_qemu_configure.patch b/app-emulation/libguestfs/files/1.26/0020_all_qemu_configure.patch
new file mode 100644
index 000000000000..77423f73e8c9
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.26/0020_all_qemu_configure.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/528386
+
+From 101d728e80cce73b882aac7af457013491d03311 Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Tue, 22 Apr 2014 22:21:57 -0400
+Subject: [PATCH] configure: Make sure grep matches qemu 2.x version string.
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 34e4ddb..bb1a361 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -777,7 +777,7 @@ working.
+ fi
+
+ AC_MSG_CHECKING([for $QEMU version >= 1])
+- if $QEMU -version | grep -sq 'version @<:@1-@:>@'; then
++ if $QEMU -version | grep -sq 'version @<:@1-9@:>@'; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+--
+2.1.3
+
diff --git a/app-emulation/libguestfs/files/1.26/0103_disable_php_bindings_makefile.patch b/app-emulation/libguestfs/files/1.26/0103_disable_php_bindings_makefile.patch
new file mode 100644
index 000000000000..34ab42d27903
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.26/0103_disable_php_bindings_makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -88,9 +88,6 @@
+ if HAVE_HASKELL
+ SUBDIRS += haskell
+ endif
+-if HAVE_PHP
+-SUBDIRS += php
+-endif
+ if HAVE_ERLANG
+ SUBDIRS += erlang erlang/examples
+ endif