summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libvirt-snmp')
-rw-r--r--app-emulation/libvirt-snmp/Manifest1
-rw-r--r--app-emulation/libvirt-snmp/libvirt-snmp-0.0.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/libvirt-snmp/Manifest b/app-emulation/libvirt-snmp/Manifest
index ea3d956712ab..b7eb38bce372 100644
--- a/app-emulation/libvirt-snmp/Manifest
+++ b/app-emulation/libvirt-snmp/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-snmp-0.0.2.tar.gz 152790 BLAKE2B b2e5eee2d67283112556c52921b14029a90d5cedf0c4575e056475191470a4b6bf5d837f1ca942b848f6509da4aa12daa508bbfc5272e1435e73fbfc290e1967 SHA512 13a522c765d278d3b8f8ab9f32f97c8531f6d131afcb0ce62ae397631db92ed3b585ad221a1f2b3bc17907cc4d61adca4a2071b0458a05f2bff5ca06191e1478
DIST libvirt-snmp-0.0.3.tar.gz 161186 BLAKE2B 1b43e7e81a43d4e969e2e30d7d62776743b3c5fb19929fb1606850946c665ad1ca662bee88743f60f202cd92fc42be1cc2cc94e99bf1d137df61bec09850de93 SHA512 6ffda3594ddc513e05e31e7d347a12e371dca3cc698ca790a70e2d01b2ceac6acb5dd6e3cd19723817b41aa62e0c0a49c01c47cb9ce379ac491856a7e88e5a08
+DIST libvirt-snmp-0.0.4.tar.gz 157859 BLAKE2B e2c8fcdd97ba9b55bd4d318c63f7738024c1360ee10aa4e685c2ea6ca02478206febff30f3e1a82eb1a2dadaa52a377cfbce538e12e33f4ea2fe10b1a089945d SHA512 dbf47e7983f9bd6fcff205fffd1f6006268cca774cf427d39dec84dc7de37b545c0dfcbb2c6f171f55d73487cdec13341097137e24de2dea58ce90494d281162
diff --git a/app-emulation/libvirt-snmp/libvirt-snmp-0.0.4.ebuild b/app-emulation/libvirt-snmp/libvirt-snmp-0.0.4.ebuild
new file mode 100644
index 000000000000..f0eb657001f9
--- /dev/null
+++ b/app-emulation/libvirt-snmp/libvirt-snmp-0.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Provides SNMP functionality for libvirt"
+HOMEPAGE="http://libvirt.org"
+SRC_URI="http://www.libvirt.org/sources/snmp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-emulation/libvirt
+ net-analyzer/net-snmp"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/libvirt-snmp.initd-r1" "${PN}"
+ newconfd "${FILESDIR}/libvirt-snmp.confd" "${PN}"
+}
+
+pkg_postinst() {
+ elog "This daemon runs as an AgentX sub-daemon for snmpd. You should therefore"
+ elog "enable the AgentX functionality in snmpd by specifying the following"
+ elog "in /etc/snmp/snmpd.conf:"
+ elog " master agentx"
+ elog "It is further recommended to send traps to the localhost as well using"
+ elog "this option:"
+ elog " trap2sink localhost"
+ elog "More information is available here:"
+ elog " http://wiki.libvirt.org/page/Libvirt-snmp"
+}