summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch')
-rw-r--r--app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch b/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch
new file mode 100644
index 000000000000..6feb4c2bb01c
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-2.0.4-bash-completion.patch
@@ -0,0 +1,31 @@
+--- /config/bash/Makefile.am.orig 2016-05-18 20:40:42.238487678 +0000
++++ /config/bash/Makefile.am 2016-05-18 20:43:02.163497779 +0000
+@@ -2,12 +2,12 @@
+
+ if ENABLE_BASH
+ install-bash:
+- $(MKDIR_P) $(DESTDIR)$(sysconfdir)/bash_completion.d/
+- $(INSTALL_DATA) lxc $(DESTDIR)$(sysconfdir)/bash_completion.d/
++ $(MKDIR_P) $(DESTDIR)$(datarootdir)/bash-completion/completions/
++ $(INSTALL_DATA) lxc $(DESTDIR)$(datarootdir)/bash-completion/completions/
+
+ uninstall-bash:
+- rm -f $(DESTDIR)$(sysconfdir)/bash_completion.d/lxc
+- rmdir $(DESTDIR)$(sysconfdir)/bash_completion.d/ || :
++ rm -f $(DESTDIR)$(datarootdir)/bash-completion/completions/lxc
++ rmdir $(DESTDIR)$(datarootdir)/bash-completion/completions/ || :
+
+ install-data-local: install-bash
+ uninstall-local: uninstall-bash
+--- /config/bash/lxc.in.orig 2016-05-18 20:40:51.079488316 +0000
++++ /config/bash/lxc.in 2016-05-18 20:45:03.506506538 +0000
+@@ -1,4 +1,3 @@
+-_have lxc-start && {
+ _lxc_names() {
+ COMPREPLY=( $( compgen -W "$( lxc-ls )" "$cur" ) )
+ }
+@@ -100,4 +99,3 @@
+
+ complete -o default -F _lxc_generic_o lxc-copy
+ complete -o default -F _lxc_generic_o lxc-start-ephemeral
+-}