summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/lxc/files/lxc-2.0.6-major.patch')
-rw-r--r--app-emulation/lxc/files/lxc-2.0.6-major.patch74
1 files changed, 74 insertions, 0 deletions
diff --git a/app-emulation/lxc/files/lxc-2.0.6-major.patch b/app-emulation/lxc/files/lxc-2.0.6-major.patch
new file mode 100644
index 000000000000..beb379a53882
--- /dev/null
+++ b/app-emulation/lxc/files/lxc-2.0.6-major.patch
@@ -0,0 +1,74 @@
+Adapt to future removal of major()/minor()/makedev() from <sys/types.h>
+
+Gentoo removed it in glibc-2.24.
+
+https://bugs.gentoo.org/575232
+https://bugs.gentoo.org/604360
+diff --git a/configure.ac b/configure.ac
+index 4640c0d..71e6450 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -620,4 +620,7 @@ AC_CHECK_DECLS([PR_CAPBSET_DROP], [], [], [#include <sys/prctl.h>])
+ AC_CHECK_HEADERS([sys/signalfd.h pty.h ifaddrs.h sys/capability.h sys/personality.h utmpx.h sys/timerfd.h])
+
++# lookup major()/minor()/makedev()
++AC_HEADER_MAJOR
++
+ # Check for some syscalls functions
+ AC_CHECK_FUNCS([setns pivot_root sethostname unshare rand_r confstr faccessat])
+diff --git a/src/lxc/bdev/lxclvm.c b/src/lxc/bdev/lxclvm.c
+index 3d41b10..419d1c2 100644
+--- a/src/lxc/bdev/lxclvm.c
++++ b/src/lxc/bdev/lxclvm.c
+@@ -33,8 +33,17 @@
+
+ #include "bdev.h"
++#include "config.h"
+ #include "log.h"
+ #include "lxclvm.h"
+ #include "utils.h"
+
++/* major()/minor() */
++#ifdef MAJOR_IN_MKDEV
++# include <sys/mkdev.h>
++#endif
++#ifdef MAJOR_IN_SYSMACROS
++# include <sys/sysmacros.h>
++#endif
++
+ lxc_log_define(lxclvm, lxc);
+
+diff --git a/src/lxc/conf.c b/src/lxc/conf.c
+index c54ee41..9a00e7f 100644
+--- a/src/lxc/conf.c
++++ b/src/lxc/conf.c
+@@ -40,4 +40,12 @@
+ #include <time.h>
+
++/* makedev() */
++#ifdef MAJOR_IN_MKDEV
++# include <sys/mkdev.h>
++#endif
++#ifdef MAJOR_IN_SYSMACROS
++# include <sys/sysmacros.h>
++#endif
++
+ #ifdef HAVE_STATVFS
+ #include <sys/statvfs.h>
+diff --git a/src/lxc/lxccontainer.c b/src/lxc/lxccontainer.c
+index 3a9e1e3..fe75fcc 100644
+--- a/src/lxc/lxccontainer.c
++++ b/src/lxc/lxccontainer.c
+@@ -62,4 +62,12 @@
+ #include "version.h"
+
++/* major()/minor() */
++#ifdef MAJOR_IN_MKDEV
++# include <sys/mkdev.h>
++#endif
++#ifdef MAJOR_IN_SYSMACROS
++# include <sys/sysmacros.h>
++#endif
++
+ #if HAVE_IFADDRS_H
+ #include <ifaddrs.h>