summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/protontricks')
-rw-r--r--app-emulation/protontricks/Manifest4
-rw-r--r--app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch36
-rw-r--r--app-emulation/protontricks/protontricks-1.10.5.ebuild (renamed from app-emulation/protontricks/protontricks-1.6.0.ebuild)29
-rw-r--r--app-emulation/protontricks/protontricks-1.11.1.ebuild (renamed from app-emulation/protontricks/protontricks-1.5.2.ebuild)33
4 files changed, 34 insertions, 68 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index e91938f98fd5..792b86075eb6 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,2 +1,2 @@
-DIST protontricks-1.5.2.tar.gz 49590 BLAKE2B 9a4f6b5869d2d23d104c3785a99549e74168d7dea429bed78ed00029ed6431460bab2c8fdd4f3905943b3e93075dea4bc9b0bf472f0044e5cbae3c335d128c12 SHA512 9e57c7ea61ae9a6638ee967041672a85962c9210fe329600bf30ab78f46b2a23cc6f859fb78e50e94686794b3fad81185d83222ca8f67e1dc73b578df7dcd411
-DIST protontricks-1.6.0.tar.gz 61220 BLAKE2B 8a9af6f8cc134ad0e74b4c5e6c35bc8344687e65cc9811ca54402b16f723264cef8def6e733a532fd412db51d0ec63533baec52699ae994a97ecad0a25ebe847 SHA512 7276d7de1f0c18afc5c67552290888e3851bd5f073bbbf684000be66c2e65abac84b079373b120ff0ab6e4f4919caf8ee1288a2320de6c37629cb1185dfbea29
+DIST protontricks-1.10.5.tar.gz 163931 BLAKE2B 299fd6c77460de3d2fa1b585a1ad3dae857e4b78898c753007b358cc25b82918d33cb31c2028a4b1b562ee6c20b95ebafc532d97e2bc1fa5358464c6a4c1da5c SHA512 305b27ceaf428946a0ed09994173c861da1097c0bd21eebcc8b255bed3c4c50a920f0cc422601fbd44e0af373b71e928096fdd6f4cc2aa05c88126212fb4401f
+DIST protontricks-1.11.1.tar.gz 166843 BLAKE2B af6692b081d1d819bef39fd69c2108454b6dfcc29b004415a73aa0c0463e3887ddffe0e10864799f665f81fc90e5365accab1722af046f50a08bb7ba221f7e23 SHA512 eb0233180ba41c91ba78072ea2aabe9e8fea5b452fba0fd56aaf17e0282b0ee04e81d3665a7be546e3112382e0b574bb077af6b6be6ad2156dabc3112a1b831b
diff --git a/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch b/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch
deleted file mode 100644
index a19d8494657b..000000000000
--- a/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Since version 1.4.1 upstream has used setuptools-scm to determine the
-current version number. Unfortunately the package in question does not
-support GitHub release archives, using GitHub VCS snapshots would require
-retrieving and updating commit hashes corresponding to release tags, and
-PyPI tarballs do not contain tests. setuptools_scm_git_archive does not
-help because it requires extra files to be included in the repository,
-which upstream has not done.
-
-Seeing as we already know the version number, bypass setuptools_scm
-altogether and create the version file ourselves. For obvious reasons the
-latter has to be done in ebuilds themselves.
-
---- a/setup.py
-+++ b/setup.py
-@@ -16,9 +16,6 @@
-
- setup(
- name="protontricks",
-- use_scm_version={
-- "write_to": "src/protontricks/_version.py"
-- },
- description=DESCRIPTION,
- long_description=LONG_DESCRIPTION,
- author=AUTHOR,
-@@ -28,11 +25,6 @@
- packages=["protontricks"],
- package_data={"": ["LICENSE"]},
- package_dir={"protontricks": "src/protontricks"},
-- setup_requires=[
-- # setuptools-scm v6 requires Python 3.6+
-- "setuptools_scm<6 ; python_version <= '3.5'",
-- "setuptools_scm ; python_version > '3.5'"
-- ],
- install_requires=["vdf>=3.2"],
- entry_points={
- "console_scripts": [
diff --git a/app-emulation/protontricks/protontricks-1.6.0.ebuild b/app-emulation/protontricks/protontricks-1.10.5.ebuild
index 2f2c167b9165..4c4ddf7953ad 100644
--- a/app-emulation/protontricks/protontricks-1.6.0.ebuild
+++ b/app-emulation/protontricks/protontricks-1.10.5.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 pypi xdg-utils
DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
HOMEPAGE="https://github.com/Matoking/protontricks"
-SRC_URI="https://github.com/Matoking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -20,6 +19,8 @@ IUSE="+gui"
RDEPEND="app-emulation/winetricks
$(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/vdf[${PYTHON_USEDEP}]
')
gui? ( gnome-extra/zenity
@@ -28,21 +29,17 @@ RDEPEND="app-emulation/winetricks
app-emulation/winetricks[kde]
)
)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0_no-setuptools-scm.patch
-)
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
DOCS=( CHANGELOG.md README.md )
distutils_enable_tests pytest
-python_prepare_all() {
- distutils-r1_python_prepare_all
- echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
-}
-
pkg_postinst() {
+ xdg_desktop_database_update
+
elog
if ! use gui; then
@@ -55,3 +52,7 @@ pkg_postinst() {
elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
elog
}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-emulation/protontricks/protontricks-1.5.2.ebuild b/app-emulation/protontricks/protontricks-1.11.1.ebuild
index 9db87c7635ec..fc9689a51050 100644
--- a/app-emulation/protontricks/protontricks-1.5.2.ebuild
+++ b/app-emulation/protontricks/protontricks-1.11.1.ebuild
@@ -1,25 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
+inherit distutils-r1 pypi xdg-utils
DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
HOMEPAGE="https://github.com/Matoking/protontricks"
-SRC_URI="https://github.com/Matoking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64"
+KEYWORDS="~amd64"
IUSE="+gui"
RDEPEND="app-emulation/winetricks
$(python_gen_cond_dep '
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/vdf[${PYTHON_USEDEP}]
')
gui? ( gnome-extra/zenity
@@ -28,21 +29,17 @@ RDEPEND="app-emulation/winetricks
app-emulation/winetricks[kde]
)
)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0_no-setuptools-scm.patch
-)
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
DOCS=( CHANGELOG.md README.md )
distutils_enable_tests pytest
-python_prepare_all() {
- distutils-r1_python_prepare_all
- echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
-}
-
pkg_postinst() {
+ xdg_desktop_database_update
+
elog
if ! use gui; then
@@ -55,3 +52,7 @@ pkg_postinst() {
elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
elog
}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}