summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/sen/sen-0.6.1_p20200905.ebuild')
-rw-r--r--app-emulation/sen/sen-0.6.1_p20200905.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-emulation/sen/sen-0.6.1_p20200905.ebuild b/app-emulation/sen/sen-0.6.1_p20200905.ebuild
deleted file mode 100644
index fe1a19b03c8f..000000000000
--- a/app-emulation/sen/sen-0.6.1_p20200905.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-COMMIT="02e5872ee2905861e1da06ab5174e1a3f41f0e0b"
-
-DESCRIPTION="Terminal User Interface for docker engine"
-HOMEPAGE="https://github.com/TomasTomecek/sen"
-SRC_URI="https://github.com/TomasTomecek/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="dev-python/urwid[${PYTHON_USEDEP}]
- dev-python/urwidtrees[${PYTHON_USEDEP}]
- dev-python/docker-py[${PYTHON_USEDEP}]
- "
-BDEPEND="
- test? (
- dev-python/flexmock[${PYTHON_USEDEP}]
- )
- "
-
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- dodoc -r docs
-}
-
-python_test() {
- epytest tests
-}