summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spice/spice-0.13.1-r2.ebuild')
-rw-r--r--app-emulation/spice/spice-0.13.1-r2.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/app-emulation/spice/spice-0.13.1-r2.ebuild b/app-emulation/spice/spice-0.13.1-r2.ebuild
index 80cf44adb644..0a9437888f8b 100644
--- a/app-emulation/spice/spice-0.13.1-r2.ebuild
+++ b/app-emulation/spice/spice-0.13.1-r2.ebuild
@@ -41,10 +41,6 @@ DEPEND="
smartcard? ( app-emulation/qemu[smartcard] )
${RDEPEND}"
-# Prevent sandbox violations, bug #586560
-# https://bugzilla.gnome.org/show_bug.cgi?id=581836
-addpredict /dev
-
python_check_deps() {
has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
has_version "dev-python/six[${PYTHON_USEDEP}]"
@@ -68,6 +64,11 @@ src_prepare() {
}
src_configure() {
+ # Prevent sandbox violations, bug #586560
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
econf \
$(use_enable static-libs static) \
$(use_enable lz4) \
@@ -76,6 +77,15 @@ src_configure() {
--disable-gui
}
+src_compile() {
+ # Prevent sandbox violations, bug #586560
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ addpredict /dev
+
+ default
+}
+
src_install() {
default
use static-libs || prune_libtool_files