summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/virtualbox-modules')
-rw-r--r--app-emulation/virtualbox-modules/Manifest2
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-5.2.28.ebuild51
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-6.0.6.ebuild52
3 files changed, 105 insertions, 0 deletions
diff --git a/app-emulation/virtualbox-modules/Manifest b/app-emulation/virtualbox-modules/Manifest
index 62665f9e6113..7520c1ec60a6 100644
--- a/app-emulation/virtualbox-modules/Manifest
+++ b/app-emulation/virtualbox-modules/Manifest
@@ -1,5 +1,7 @@
DIST vbox-kernel-module-src-5.2.22.tar.xz 638492 BLAKE2B 71aba29b056bb3dfeffbf4632fbf7f15d89b988267ba24c766b78b1d9c50a4d27fb1b8e699108b973af68024f9f77ca0a8ad787355d7342fe1400f14189487ff SHA512 3361bb536af8e8d490377be04d1b1b9af478538e23ec409d3e0205ad930c16e5228c57ae7d92d214ac533ae64298d9eaff3c9284ff9bb308108d1ad7d69fb507
DIST vbox-kernel-module-src-5.2.24.tar.xz 642124 BLAKE2B fbf077b1d94f0b2f6ccb1a9a9f2e9b6f2b02153659f60a28bf3905bbd9aca762bcdbbe1a96ff602048a4d43eb61b8195c1c511bea7248d0593efd7972a17fc5b SHA512 ba0dc0ba4964eb17c421f624e321369a96564f08daa7e6949db9cbde2a182cd29a51f7b0a3215938789bb61e2427cbd38e318e5d909fd54d243ef764f51eb0e4
DIST vbox-kernel-module-src-5.2.26.tar.xz 642096 BLAKE2B fa908b8dda4c49e880005f22d4ec159ba4e84b20d3cf8f514ec5ad0ea556499b0df25fb714bb5f9a3474e6fc1cba67f6d56fddaee748b9561bbe31a003dd0657 SHA512 7f37be1b35772d59cd3df9b61dec436450de3c038faf2cd22fb891fee7270aa7f87f146f72497ffeb63dfe869cccd3f2788562d23fc51afd83ca19159f2a6810
+DIST vbox-kernel-module-src-5.2.28.tar.xz 642000 BLAKE2B 65ffe2345e978e0afba079e9291d55dc0419853718831d4c47e8e3e4f9fa194957342683aec0f362aa3f3924dca90d73ac30d947dec69ff54106d8e229510889 SHA512 bef0601b295d1a5cc0387262a6c75ec33777edaeaa543218bc7ddea5ced3995511978abfb624d2547fc6339c41e638054fb173ee7e0aeb46c7356a24834b3d83
DIST vbox-kernel-module-src-6.0.2.tar.xz 665352 BLAKE2B 703291334afb8662211dfc5223d66dafa496612ca917637b2d34f6d38475287a1eed00e484965c670da236fdfcc558e0c7ebd081be1f6674603af2c0b6bda549 SHA512 c05f3e89b2fc5a504e77f0617dbe9ccde8de6d9b06e4c2f6d59d90f362b2d5a8207d64b16a8c767e63066a04236934664dfd452b23f4c5a2c4a3b301e07212c9
DIST vbox-kernel-module-src-6.0.4.tar.xz 666200 BLAKE2B b7a6911a8534ae9e7db5a90fecfaf58394bf61ff1ee925302fdea46443e603535d1508b638c7c3f2440c0fe1176ca85d2f063f99632eb1a9093a9367f2e49fdc SHA512 565d635683f8a5f32c18b1bbf41b38bcab549a019cf0977c8dfbb53310494fb261e485ac11eb48e546c3c4b6ed13b3fb1628013dbc101f042ee9a61b8168122a
+DIST vbox-kernel-module-src-6.0.6.tar.xz 667936 BLAKE2B 5eca0167ad6c624bb56978c07c0184ef39d789ca5752fee3fcb00a2f5a7af4d20a69dde4288fc5233111ea821eab69d6970a86861459d09d6050d93f09f8f2ef SHA512 aff4b1f200abfdb7e249e6c725ab9c2a4c83010bd0c7b6d2d6595ae7d7bc6b2bd291f77c1597b3fb2c39de61867447c18e06d865a50565ccb07120de2c34d141
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-5.2.28.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-5.2.28.ebuild
new file mode 100644
index 000000000000..c4b01a1b3f96
--- /dev/null
+++ b/app-emulation/virtualbox-modules/virtualbox-modules-5.2.28.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# XXX: the tarball here is just the kernel modules split out of the binary
+# package that comes from virtualbox-bin
+
+EAPI=7
+
+inherit linux-mod user
+
+MY_P="vbox-kernel-module-src-${PV}"
+DESCRIPTION="Kernel Modules for Virtualbox"
+HOMEPAGE="https://www.virtualbox.org/"
+SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel"
+
+RDEPEND="!=app-emulation/virtualbox-9999"
+
+S="${WORKDIR}"
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
+
+pkg_setup() {
+ enewgroup vboxusers
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}
+
+src_prepare() {
+ if use pax_kernel && kernel_is -ge 3 0 0 ; then
+ eapply -p0 "${FILESDIR}"/${PN}-5.2.8-pax-const.patch
+ fi
+
+ default
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ doins "${FILESDIR}"/virtualbox.conf
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-6.0.6.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-6.0.6.ebuild
new file mode 100644
index 000000000000..7257cb3b5812
--- /dev/null
+++ b/app-emulation/virtualbox-modules/virtualbox-modules-6.0.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# XXX: the tarball here is just the kernel modules split out of the binary
+# package that comes from virtualbox-bin
+
+EAPI=7
+
+inherit linux-mod user
+
+MY_P="vbox-kernel-module-src-${PV}"
+DESCRIPTION="Kernel Modules for Virtualbox"
+HOMEPAGE="https://www.virtualbox.org/"
+SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="pax_kernel"
+
+RDEPEND="!=app-emulation/virtualbox-9999"
+
+S="${WORKDIR}"
+
+BUILD_TARGETS="all"
+BUILD_TARGET_ARCH="${ARCH}"
+MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
+
+pkg_setup() {
+ enewgroup vboxusers
+ linux-mod_pkg_setup
+ BUILD_PARAMS="CC=$(tc-getBUILD_CC) KERN_DIR=${KV_DIR} KERN_VER=${KV_FULL} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
+}
+
+src_prepare() {
+ if use pax_kernel && kernel_is -ge 3 0 0 ; then
+ eapply -p0 "${FILESDIR}"/${PN}-5.2.8-pax-const.patch
+ fi
+
+ default
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /usr/lib/modules-load.d/
+ doins "${FILESDIR}"/virtualbox.conf
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+}