summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vpcs')
-rw-r--r--app-emulation/vpcs/Manifest1
-rw-r--r--app-emulation/vpcs/metadata.xml15
-rw-r--r--app-emulation/vpcs/vpcs-0.6.ebuild45
3 files changed, 61 insertions, 0 deletions
diff --git a/app-emulation/vpcs/Manifest b/app-emulation/vpcs/Manifest
new file mode 100644
index 000000000000..cb70521268cf
--- /dev/null
+++ b/app-emulation/vpcs/Manifest
@@ -0,0 +1 @@
+DIST vpcs-0.6-src.tbz 131820 SHA256 cc311b0dea9ea02ef95f26704d73e34d293caa503600a0acca202d577afd3ceb SHA512 a740f264551de9e8dd95de2fbba444d9525f63c4c5473aea6cf1016c99d7866f3d0623f9f934bda7a0b565c23179647734c400ce3bb685fdab8ec6c35f25d671 WHIRLPOOL a4396f11ed64583ee5d0c7a681fb8f05c792b27eaac057b3ad85d63173d7ccdb7cd679e4b0a1a0f2904d64c51d922f75ab08b638053a0364443f4a0661b80fda
diff --git a/app-emulation/vpcs/metadata.xml b/app-emulation/vpcs/metadata.xml
new file mode 100644
index 000000000000..2391c644fe52
--- /dev/null
+++ b/app-emulation/vpcs/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>aaron@flappyport.com</email>
+ <name>Arron Bauman</name>
+ <description>proxy maintainer</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">vpcs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/vpcs/vpcs-0.6.ebuild b/app-emulation/vpcs/vpcs-0.6.ebuild
new file mode 100644
index 000000000000..9385b1d70ad4
--- /dev/null
+++ b/app-emulation/vpcs/vpcs-0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simulate up to 9 PCs in place of VMware boxes in a Dynamips network"
+HOMEPAGE="http://vpcs.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.tbz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${S}/src/"
+
+src_prepare() {
+ # move Makefile in place
+ cp Makefile.linux Makefile
+
+ # replace hardcoded CFLAGS with user set CFLAGS
+ # append -fno-strict-aliasing to CFLAGS to suppress QA issues from upstream
+ # add user $LDFLAGS in the front and remove -s that strips binary
+ sed -e "s/-D\$(CPUTYPE)/${CFLAGS} -fno-strict-aliasing/" \
+ -e "s/^LDFLAGS=/LDFLAGS=${LDFLAGS} /" \
+ -e "s/-s //" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ #put binary in /usr/bin
+ dobin vpcs
+
+ doman ../man/vpcs.1
+}