summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-2.0-r1.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-2.0-r1.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/app-emulation/wine-staging/wine-staging-2.0-r1.ebuild b/app-emulation/wine-staging/wine-staging-2.0-r1.ebuild
index 0c4b6b962ecf..1aeafd492e5a 100644
--- a/app-emulation/wine-staging/wine-staging-2.0-r1.ebuild
+++ b/app-emulation/wine-staging/wine-staging-2.0-r1.ebuild
@@ -152,7 +152,6 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- dev-util/patchbin
sys-devel/flex
>=sys-kernel/linux-headers-2.6
virtual/pkgconfig
@@ -176,6 +175,23 @@ usr/share/applications/wine-notepad.desktop
usr/share/applications/wine-uninstaller.desktop
usr/share/applications/wine-winecfg.desktop"
+PATCHES=(
+ "${PATCHDIR}/patches/${MY_PN}-1.5.26-winegcc.patch" #260726
+ "${PATCHDIR}/patches/${MY_PN}-1.9.5-multilib-portage.patch" #395615
+ "${PATCHDIR}/patches/${MY_PN}-1.6-memset-O3.patch" #480508
+ "${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch"
+ "${PATCHDIR}/patches/freetype-2.8.1-segfault.patch" #631676
+ "${PATCHDIR}/patches/freetype-2.8.1-drop-glyphs.patch" #631376
+)
+PATCHES_BIN=(
+ "${PATCHDIR}/patches/freetype-2.8.1-patch-fonts.patch" #631376
+)
+
+# https://bugs.gentoo.org/show_bug.cgi?id=635222
+if [[ ${#PATCHES_BIN[@]} -ge 1 ]] || [[ ${PV} == 9999 ]]; then
+ DEPEND+=" dev-util/patchbin"
+fi
+
wine_compiler_check() {
[[ ${MERGE_TYPE} = "binary" ]] && return 0
@@ -347,17 +363,7 @@ src_prepare() {
}
local md5="$(md5sum server/protocol.def)"
- local PATCHES=(
- "${PATCHDIR}/patches/${MY_PN}-1.5.26-winegcc.patch" #260726
- "${PATCHDIR}/patches/${MY_PN}-1.9.5-multilib-portage.patch" #395615
- "${PATCHDIR}/patches/${MY_PN}-1.6-memset-O3.patch" #480508
- "${PATCHDIR}/patches/${MY_PN}-2.0-multislot-apploader.patch"
- "${PATCHDIR}/patches/freetype-2.8.1-segfault.patch" #631676
- "${PATCHDIR}/patches/freetype-2.8.1-drop-glyphs.patch" #631376
- )
- local PATCHES_BIN=(
- "${PATCHDIR}/patches/freetype-2.8.1-patch-fonts.patch" #631376
- )
+
if use staging; then
ewarn "Applying the Wine-Staging patchset. Any bug reports to the"
ewarn "Wine bugzilla should explicitly state that staging was used."