summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/lxd/Manifest1
-rw-r--r--app-emulation/lxd/files/lxd-0.24-dont-go-get.patch18
-rw-r--r--app-emulation/lxd/files/lxd-0.24-nc-binary-name.patch11
-rw-r--r--app-emulation/lxd/files/lxd-0.24.confd27
-rw-r--r--app-emulation/lxd/files/lxd-0.24.initd50
-rw-r--r--app-emulation/lxd/lxd-0.24.ebuild157
6 files changed, 264 insertions, 0 deletions
diff --git a/app-emulation/lxd/Manifest b/app-emulation/lxd/Manifest
index d8beda6bf52c..9581399ca401 100644
--- a/app-emulation/lxd/Manifest
+++ b/app-emulation/lxd/Manifest
@@ -2,3 +2,4 @@ DIST lxd-0.20.tar.bz2 2687718 SHA256 a071b92015f676746137e1ffeab1886d90297d0d583
DIST lxd-0.21.tar.bz2 2683517 SHA256 06e9ed72d1d45af532664e47d9772a886dc1d757e83d673498b05798249c66c8 SHA512 588225ed77cd8a86b34579ee3f3b2b3ba8166ce9d85872e6076fa5075bc5a3846c82255dee6e701a6d51bdd9bf8280bbd5fab08ca4438de5320de8f0388685eb WHIRLPOOL c85f103e38f44c4cd859faf330764c3d076cede6d09f976b4686d7f91b6ca233e09721df418493fed19cb8bf3118b2a0a6723f3084da532bba4a5344de8a4b9c
DIST lxd-0.22.tar.bz2 2685133 SHA256 66dc30b82fba7f606658280d0dbac67a32152644a403ab00285fc3907b50082e SHA512 ab5384143edd03dfa1ef956c64e9fce2d845ce07c5388f719c202fd1ff9059282e104400f39f23ff1c4fefc8a23dd1d4c6c9094b497c40c659b087989bf07d44 WHIRLPOOL 27559c50f6aa55edb533046bb49b04784c63003569e7920261504a7b4c69891a80ff8432421352c13f274bb21876f2cf5266e9de2b1302d69e0254be87c17137
DIST lxd-0.23.tar.bz2 2606330 SHA256 06335bd15b00db2dec06114427b1d934fe1ac5271b85eb19074c508cb2466695 SHA512 2f73817c800c55c722a3017ee3064587c04730d5da9846b44be99b4541e739b466bcb7e924fcb18a15f1d49d010d471510378060530f6a15f6e60363b4d556b3 WHIRLPOOL 455b782ed2d21d5a720e06e356e1dd2115df174893e66710c74d02596deb8a66ff6e77b400f2ebeb047209b3bfed0927ff21a3a9f7cf9924719b84742f0eb5a7
+DIST lxd-0.24.tar.bz2 1973022 SHA256 e3851bded0f2639e4aec9c63797135bfa3b27def17123c8e506c784b1ab4c99a SHA512 e7593136fd1fb13542a8415d964ff3bab8bcc7f7a7d806874e7c21fd9d96652aa5716a9d3318cea3d849a19aa96b40bfea27f4edd528c8307efaeeac88971f2e WHIRLPOOL 69b6722a25c9e75e533436a37951dc893cbf3d3c0f5d31b3ccc2cf0a7dede9cf16c53e68562348ab9bf9e621421030b826df21e5fb32df8a496127601fa5d898
diff --git a/app-emulation/lxd/files/lxd-0.24-dont-go-get.patch b/app-emulation/lxd/files/lxd-0.24-dont-go-get.patch
new file mode 100644
index 000000000000..1b229ea99cd5
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-0.24-dont-go-get.patch
@@ -0,0 +1,18 @@
+--- Makefile.orig 2015-09-17 20:37:16.481867339 -0500
++++ Makefile 2015-09-17 20:53:27.715800926 -0500
+@@ -12,15 +12,11 @@
+
+ .PHONY: default
+ default:
+- -go get -t -v -d ./...
+- -go get -t -v -d ./...
+ go install -v ./...
+ @echo "LXD built succesfuly"
+
+ .PHONY: client
+ client:
+- -go get -t -v -d ./...
+- -go get -t -v -d ./...
+ go install -v ./lxc
+ @echo "LXD client built succesfuly"
+
diff --git a/app-emulation/lxd/files/lxd-0.24-nc-binary-name.patch b/app-emulation/lxd/files/lxd-0.24-nc-binary-name.patch
new file mode 100644
index 000000000000..7373b66969b7
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-0.24-nc-binary-name.patch
@@ -0,0 +1,11 @@
+--- lxd/rsync.go.orig 2015-11-11 20:54:37.402700202 -0600
++++ lxd/rsync.go 2015-11-11 20:55:06.704698199 -0600
+@@ -91,7 +91,7 @@
+ * command (i.e. the command to run on --server). However, we're
+ * hardcoding that at the other end, so we can just ignore it.
+ */
+- rsyncCmd := fmt.Sprintf("sh -c \"nc -U %s\"", f.Name())
++ rsyncCmd := fmt.Sprintf("sh -c \"nc.openbsd -U %s\"", f.Name())
+ cmd := exec.Command(
+ "rsync",
+ "-arvP",
diff --git a/app-emulation/lxd/files/lxd-0.24.confd b/app-emulation/lxd/files/lxd-0.24.confd
new file mode 100644
index 000000000000..3d553276a5e3
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-0.24.confd
@@ -0,0 +1,27 @@
+# Group which owns the shared socket
+LXD_OPTIONS+=" --group lxd"
+
+
+
+# Enable cpu profiling into the specified file
+#LXD_OPTIONS+=" --cpuprofile /tmp/lxc_cpu_profile"
+
+# Enable memory profiling into the specified file
+#LXD_OPTIONS+=" --memprofile /tmp/lxc_mem_profile"
+
+
+
+# Enables debug mode
+#LXD_OPTIONS+=" --debug"
+
+# For debugging, print a complete stack trace every n seconds
+#LXD_OPTIONS+=" --print-goroutines-every 5"
+
+# Enables verbose mode
+#LXD_OPTIONS+=" -v"
+
+# Logfile to log to
+#LXD_OPTIONS+=" --logfile /var/log/lxd/lxd.log"
+
+# Enables syslog logging
+#LXD_OPTIONS+=" --syslog"
diff --git a/app-emulation/lxd/files/lxd-0.24.initd b/app-emulation/lxd/files/lxd-0.24.initd
new file mode 100644
index 000000000000..ec23258c19d1
--- /dev/null
+++ b/app-emulation/lxd/files/lxd-0.24.initd
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON=/usr/sbin/lxd
+PIDFILE=/run/lxd.pid
+
+extra_commands="stopall"
+
+depend() {
+ need net
+ use lxcfs
+
+ # remove with 2.0 release
+ need cgmanager
+}
+
+start() {
+ ebegin "Starting lxd server"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ ${LXD_OPTIONS}
+
+ eend $?
+}
+
+stop() {
+ if [[ $RC_GOINGDOWN = YES ]] || [[ $RC_REBOOT = YES ]]; then
+ stopall
+ else
+ ebegin "Stopping lxd service (but not containers)"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+ fi
+}
+
+stopall() {
+ ebegin "Stopping lxd service and containers"
+ if "${DAEMON}" shutdown; then
+ /etc/init.d/lxd zap
+ rm -f ${PIDFILE}
+ fi
+ eend $?
+}
diff --git a/app-emulation/lxd/lxd-0.24.ebuild b/app-emulation/lxd/lxd-0.24.ebuild
new file mode 100644
index 000000000000..549dff584e5f
--- /dev/null
+++ b/app-emulation/lxd/lxd-0.24.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Fast, dense and secure container management"
+HOMEPAGE="https://linuxcontainers.org/lxd/introduction/"
+EGO_PN_PARENT="github.com/lxc"
+EGO_PN="${EGO_PN_PARENT}/lxd"
+SRC_URI="https://dev.gentoo.org/~stasibear/distfiles/${P}.tar.bz2"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PLOCALES="de fr ja"
+IUSE="+daemon nls test"
+
+# IUSE and PLOCALES must be defined before l10n inherited
+inherit bash-completion-r1 eutils golang-build l10n systemd user vcs-snapshot
+
+# The compiler is forced in golang-base:
+# DEPEND=">=dev-lang/go-1.4.2:="
+# ... so the dep is omitted here (and I disagree with := in this case)
+
+DEPEND="
+ dev-go/go-crypto
+ dev-libs/protobuf
+ dev-vcs/git
+ nls? ( sys-devel/gettext )
+ test? (
+ app-misc/jq
+ dev-db/sqlite
+ net-misc/curl
+ sys-devel/gettext
+ )
+"
+
+RDEPEND="
+ daemon? (
+ app-admin/cgmanager
+ app-arch/xz-utils
+ app-emulation/lxc[cgmanager,seccomp]
+ net-analyzer/openbsd-netcat
+ net-misc/bridge-utils
+ net-misc/rsync[xattr]
+ sys-apps/iproute2
+ virtual/acl
+ )
+"
+
+# KNOWN ISSUES:
+# - Translations may not work. I've been unsuccessful in forcing
+# localized output. Anyway, upstream (Canonical) doesn't install the
+# message files.
+
+# TODO:
+# - since 0.15 gccgo is a supported compiler ('make gccgo'). It would
+# be preferable for that support to go into the golang-build eclass not
+# this package directly.
+
+src_prepare() {
+ cd "${S}/src/${EGO_PN}" || die "Failed to change to deep src dir"
+
+ epatch "${FILESDIR}/${P}-dont-go-get.patch"
+
+ # Upstream requires the openbsd flavor of netcat (with -U), but
+ # Gentoo installs that with a renamed binary
+ epatch "${FILESDIR}/${P}-nc-binary-name.patch"
+
+ # Warn on unhandled locale changes
+ l10n_find_plocales_changes po "" .po
+}
+
+src_compile() {
+ golang-build_src_compile
+
+ cd "${S}/src/${EGO_PN}" || die "Failed to change to deep src dir"
+
+ if use daemon; then
+ # Build binaries
+ GOPATH="${S}:$(get_golibdir_gopath)" emake
+ else
+ # build client tool
+ GOPATH="${S}:$(get_golibdir_gopath)" emake client
+ fi
+
+ use nls && emake build-mo
+}
+
+src_test() {
+ if use daemon; then
+ # Go native tests should succeed
+ golang-build_src_test
+ fi
+}
+
+src_install() {
+ # Installs all src,pkg to /usr/lib/go-gentoo
+ golang-build_src_install
+
+ cd "${S}"
+ dobin bin/lxc
+ use daemon && dosbin bin/lxd
+
+ cd "src/${EGO_PN}"
+
+ if use nls; then
+ for lingua in ${PLOCALES}; do
+ if use linguas_${lingua}; then
+ domo po/${lingua}.mo
+ fi
+ done
+ fi
+
+ if use daemon; then
+ newinitd "${FILESDIR}"/${P}.initd lxd
+ newconfd "${FILESDIR}"/${P}.confd lxd
+
+ systemd_dounit "${FILESDIR}"/lxd.service
+ fi
+
+ newbashcomp config/bash/lxc.in lxc
+
+ dodoc AUTHORS CONTRIBUTING.md README.md
+
+ docinto specs
+ dodoc specs/*
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Consult https://wiki.gentoo.org/wiki/LXD for more information,"
+ einfo "including a Quick Start."
+
+ # The messaging below only applies to daemon installs
+ use daemon || return 0
+
+ # The control socket will be owned by (and writeable by) this group.
+ enewgroup lxd
+
+ # Ubuntu also defines an lxd user but it appears unused (the daemon
+ # must run as root)
+
+ einfo
+ einfo "Though not strictly required, some features are enabled at run-time"
+ einfo "when the relevant helper programs are detected:"
+ einfo "- sys-apps/apparmor"
+ einfo "- sys-fs/btrfs-progs"
+ einfo "- sys-fs/lvm2"
+ einfo "- sys-fs/lxcfs"
+ einfo "- sys-fs/zfs"
+ einfo "- sys-process/criu"
+ einfo
+ einfo "Since these features can't be disabled at build-time they are"
+ einfo "not USE-conditional."
+}