summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/libewf')
-rw-r--r--app-forensics/libewf/files/libewf-20171104-openssl-3.patch27
-rw-r--r--app-forensics/libewf/libewf-20171104-r2.ebuild (renamed from app-forensics/libewf/libewf-20171104-r1.ebuild)23
2 files changed, 43 insertions, 7 deletions
diff --git a/app-forensics/libewf/files/libewf-20171104-openssl-3.patch b/app-forensics/libewf/files/libewf-20171104-openssl-3.patch
new file mode 100644
index 000000000000..2d30da7042f8
--- /dev/null
+++ b/app-forensics/libewf/files/libewf-20171104-openssl-3.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/805188
+https://github.com/libyal/libewf/commit/033ea5b4e5f8f1248f74a2ec61fc1be183c6c46b
+--- a/ewftools/ewftools_output.c
++++ b/ewftools/ewftools_output.c
+@@ -238,12 +238,20 @@ void ewfoutput_version_detailed_fprint(
+ LIBHMAC_VERSION_STRING );
+
+ #if defined( HAVE_LIBCRYPTO )
++#if defined( SHLIB_VERSION_NUMBER )
+ fprintf(
+ stream,
+ " (libcrypto %s)",
+ SHLIB_VERSION_NUMBER );
+-#endif
+-#endif
++#elif defined( OPENSSL_VERSION_MAJOR ) && defined( OPENSSL_VERSION_MINOR )
++ fprintf(
++ stream,
++ " (libcrypto %d.%d)",
++ OPENSSL_VERSION_MAJOR,
++ OPENSSL_VERSION_MINOR );
++#endif
++#endif
++#endif
+
+ #if defined( HAVE_LIBODRAW ) || defined( HAVE_LOCAL_LIBODRAW )
+ fprintf(
diff --git a/app-forensics/libewf/libewf-20171104-r1.ebuild b/app-forensics/libewf/libewf-20171104-r2.ebuild
index 6e872b922cf9..b45a35d521a8 100644
--- a/app-forensics/libewf/libewf-20171104-r1.ebuild
+++ b/app-forensics/libewf/libewf-20171104-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,12 +9,12 @@ SRC_URI="https://github.com/libyal/libewf/releases/download/${PV}/${PN}-experime
LICENSE="BSD"
SLOT="0/3"
-KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 ~riscv x86"
-# upstream bug #2597171, pyewf has implicit declarations
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ~ppc64 ~riscv x86"
+# Upstream bug #2597171, pyewf has implicit declarations
#IUSE="debug python unicode"
IUSE="bfio bzip2 debug +fuse nls +ssl static-libs +uuid unicode zlib"
-# uses bundled libbfio until tree version is bumped
+# Uses bundled libbfio until tree version is bumped
RDEPEND="
bzip2? ( app-arch/bzip2 )
fuse? ( sys-fs/fuse:0= )
@@ -26,14 +26,19 @@ RDEPEND="
ssl? ( dev-libs/openssl:0= )
zlib? ( sys-libs/zlib )
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )
"
-# issues finding test executables
+# Issues finding test executables
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${P}-openssl-3.patch
+)
+
src_configure() {
local econfargs=(
$(use_enable static-libs static)
@@ -48,10 +53,14 @@ src_configure() {
$(use_with uuid libuuid)
$(use_with fuse libfuse)
)
+
econf "${econfargs[@]}"
}
src_install() {
default
- use static-libs || find "${ED}"/usr -name '*.la' -delete
+
+ if ! use static-libs ; then
+ find "${ED}"/usr -name '*.la' -delete || die
+ fi
}