summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fbterm/fbterm-1.7-r2.ebuild')
-rw-r--r--app-i18n/fbterm/fbterm-1.7-r2.ebuild53
1 files changed, 25 insertions, 28 deletions
diff --git a/app-i18n/fbterm/fbterm-1.7-r2.ebuild b/app-i18n/fbterm/fbterm-1.7-r2.ebuild
index 5685cd6a76e3..536c70f0606b 100644
--- a/app-i18n/fbterm/fbterm-1.7-r2.ebuild
+++ b/app-i18n/fbterm/fbterm-1.7-r2.ebuild
@@ -1,60 +1,57 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-inherit autotools-utils
+EAPI="6"
+
+inherit autotools
DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
HOMEPAGE="https://fbterm.googlecode.com/"
-SRC_URI="https://fbterm.googlecode.com/files/${P}.0.tar.gz"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.0.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="caps gpm video_cards_vesa"
-RDEPEND="caps? ( sys-libs/libcap )
+RDEPEND="media-libs/fontconfig
+ media-libs/freetype:2
+ caps? ( sys-libs/libcap )
gpm? ( sys-libs/gpm )
- video_cards_vesa? ( dev-libs/libx86 )
- media-libs/fontconfig
- media-libs/freetype:2"
+ video_cards_vesa? ( dev-libs/libx86 )"
DEPEND="${RDEPEND}
sys-libs/ncurses
virtual/pkgconfig"
-AUTOTOOLS_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}"/${PN}-gcc6.patch )
-DOCS=( AUTHORS NEWS README )
+src_prepare() {
+ sed -i "s|tic|tic -o '\$(DESTDIR)\$(datadir)/terminfo'|" terminfo/Makefile.am
-PATCHES=(
- "${FILESDIR}"/${PN}-gcc6.patch
-)
+ default
+ eautoreconf
+}
src_configure() {
- local myeconfargs=(
- $(use_enable gpm)
+ econf \
+ $(use_enable gpm) \
$(use_enable video_cards_vesa vesa)
- )
- autotools-utils_src_configure
}
src_install() {
- autotools-utils_src_install
- $(type -P tic) -o "${ED}/usr/share/terminfo/" \
- "${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
+ default
+
if use caps; then
- setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
+ setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/${PN}
else
- fperms u+s /usr/bin/fbterm
+ fperms u+s /usr/bin/${PN}
fi
}
pkg_postinst() {
- einfo
- einfo " ${PN} won't work with vga16fb. You have to use other native"
- einfo " framebuffer drivers or vesa driver."
- einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
- einfo " To use ${PN}, ensure you are in video group."
- einfo " To input CJK merge app-i18n/fbterm-ucimf"
- einfo
+ elog "${PN} won't work with vga16fb. You have to use other native"
+ elog "framebuffer drivers or vesa driver."
+ elog "See ${EPREFIX}/usr/share/doc/${P}/README for details."
+ elog
+ elog "To use ${PN}, ensure you are in video group."
}