summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch')
-rw-r--r--app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch b/app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch
new file mode 100644
index 000000000000..e21c3a1db7e8
--- /dev/null
+++ b/app-i18n/fcitx/files/fcitx-4.2.9.8-xkb.patch
@@ -0,0 +1,32 @@
+https://github.com/fcitx/fcitx/issues/250
+
+--- /CMakeLists.txt
++++ /CMakeLists.txt
+@@ -96,12 +96,15 @@
+ endif()
+ endif()
+ if (ENABLE_XKB)
+- # Parse xkb xml file
+- find_package(LibXml2 REQUIRED)
+ find_package(IsoCodes REQUIRED)
+- find_package(XkbFile REQUIRED)
+ # Parse isocodes json
+ pkg_check_modules(JsonC "json-c" IMPORTED_TARGET REQUIRED)
++ if(ENABLE_X11)
++ # Parse xkb xml file
++ find_package(LibXml2 REQUIRED)
++ find_package(XkbFile REQUIRED)
++ find_package(XKeyboardConfig REQUIRED)
++ endif(ENABLE_X11)
+ endif (ENABLE_XKB)
+ if(ENABLE_PRESAGE)
+ find_package(Presage)
+@@ -121,8 +124,6 @@
+ message(FATAL_ERROR "Xkb is needed")
+ endif (NOT X11_Xkb_FOUND)
+
+-find_package(XKeyboardConfig REQUIRED)
+-
+ endif()
+
+ if (ENABLE_TEST)