summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild')
-rw-r--r--app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild b/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild
new file mode 100644
index 000000000000..fbd71b29621b
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-1.3.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="mirror://github/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.3
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+DOCS="ChangeLog NEWS README THANKS TODO"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ >py-compile
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}