summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/uchardet/uchardet-9999.ebuild')
-rw-r--r--app-i18n/uchardet/uchardet-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/uchardet/uchardet-9999.ebuild b/app-i18n/uchardet/uchardet-9999.ebuild
new file mode 100644
index 000000000000..2d53e33d7c36
--- /dev/null
+++ b/app-i18n/uchardet/uchardet-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="An encoding detector library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/uchardet/"
+EGIT_REPO_URI=(
+ https://anongit.freedesktop.org/git/${PN}/${PN}.git
+ git://anongit.freedesktop.org/${PN}/${PN}
+)
+
+LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs test"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use test || cmake_comment_add_subdirectory test
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC=$(usex static-libs)
+ )
+ cmake-utils_src_configure
+}