summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/beep/beep-1.4.4.ebuild')
-rw-r--r--app-misc/beep/beep-1.4.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/beep/beep-1.4.4.ebuild b/app-misc/beep/beep-1.4.4.ebuild
new file mode 100644
index 000000000000..e8047db74a68
--- /dev/null
+++ b/app-misc/beep/beep-1.4.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Advanced PC speaker beeper"
+HOMEPAGE="https://github.com/spkr-beep"
+SRC_URI="https://github.com/spkr-beep/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="suid"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+
+ sed -i -e "s#-D_FORTIFY_SOURCE=2##g;" GNUmakefile || die
+}
+
+src_install() {
+ dobin beep
+ if use suid; then
+ fowners :audio /usr/bin/beep
+ fperms 4710 /usr/bin/beep
+ else
+ fperms 0711 /usr/bin/beep
+ fi
+ unpack "./${PN}.1.gz"
+ doman "${PN}.1"
+ einstalldocs
+}