summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/crunch/crunch-3.4.ebuild')
-rw-r--r--app-misc/crunch/crunch-3.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/crunch/crunch-3.4.ebuild b/app-misc/crunch/crunch-3.4.ebuild
new file mode 100644
index 000000000000..edaf0f426163
--- /dev/null
+++ b/app-misc/crunch/crunch-3.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A wordlist generator"
+HOMEPAGE="http://sourceforge.net/projects/crunch-wordlist/"
+SRC_URI="mirror://sourceforge/crunch-wordlist/crunch-wordlist/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+
+src_prepare() {
+ tc-export CC
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch_user
+}
+
+src_install(){
+ dobin crunch
+ doman crunch.1
+ insinto /usr/share/crunch
+ doins charset.lst
+}