summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/dailystrips/dailystrips-1.0.28-r4.ebuild')
-rw-r--r--app-misc/dailystrips/dailystrips-1.0.28-r4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/dailystrips/dailystrips-1.0.28-r4.ebuild b/app-misc/dailystrips/dailystrips-1.0.28-r4.ebuild
new file mode 100644
index 000000000000..b37ba7ee67b9
--- /dev/null
+++ b/app-misc/dailystrips/dailystrips-1.0.28-r4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="dailystrips automatically downloads your favorite online comics from the web"
+HOMEPAGE="http://dailystrips.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dailystrips/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86"
+
+RDEPEND="
+ dev-perl/libwww-perl
+ dev-perl/DateTime
+ dev-perl/TimeDate"
+
+src_prepare() {
+ default
+ sed -i -e "s:/usr/share/dailystrips/strips.def:${EPREFIX}/etc/strips.def:" \
+ dailystrips || die "sed dailystrips failed"
+}
+
+src_install() {
+ dobin dailystrips dailystrips-clean dailystrips-update
+ dodoc BUGS CHANGELOG CONTRIBUTORS README* TODO
+ insinto /etc
+ doins strips.def
+}