summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/hastyhex/hastyhex-1.0.0.ebuild')
-rw-r--r--app-misc/hastyhex/hastyhex-1.0.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/hastyhex/hastyhex-1.0.0.ebuild b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
new file mode 100644
index 000000000000..c8138ef7aacf
--- /dev/null
+++ b/app-misc/hastyhex/hastyhex-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A blazing fast hex dumper"
+HOMEPAGE="https://github.com/skeeto/hastyhex"
+SRC_URI="https://github.com/skeeto/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}