summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/vit')
-rw-r--r--app-misc/vit/Manifest2
-rw-r--r--app-misc/vit/metadata.xml16
-rw-r--r--app-misc/vit/vit-1.3.ebuild20
-rw-r--r--app-misc/vit/vit-2.3.2.ebuild30
4 files changed, 37 insertions, 31 deletions
diff --git a/app-misc/vit/Manifest b/app-misc/vit/Manifest
index a510b610e0b5..e455e5158c0d 100644
--- a/app-misc/vit/Manifest
+++ b/app-misc/vit/Manifest
@@ -1 +1 @@
-DIST vit-1.3.tar.gz 56035 BLAKE2B 871e29767dd5aeb39e6876981246c7d42cdbe45320e3a2524bbc3c2aa055b65a04a54ee4a2bc122c3bf689fec93f117ec7b238dd5462a9133c35cf177cf454e7 SHA512 45ae4a1d08560d534a02a046d2fcf55c5401f9aaab0abcfbd13070fee28854268ba327018aea40317a184b9e28b074973f5d3e4169a479227e94b8401f066527
+DIST vit-2.3.2.tar.gz 72321 BLAKE2B 45fb6725547f2a6703dd0862df522781f5a5fa7d7264a1c1dd95d28fcca688661c971abec789e93fa40b4c40b2c1991ca5b951b4d0439baeeb7ef7f82aed6e7a SHA512 f24a3bd238b390acb437b1a7bdd888f468196ddbf179d1aee9578ce1c83e6f973703d779c231c07024f81600066431661e312419ad5a4c81bcb1125a9f714f42
diff --git a/app-misc/vit/metadata.xml b/app-misc/vit/metadata.xml
index 4bc51f65e31c..8955cdd24077 100644
--- a/app-misc/vit/metadata.xml
+++ b/app-misc/vit/metadata.xml
@@ -1,16 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>nerdboy@gentoo.org</email>
- <name>Stephen Arnold</name>
-</maintainer>
-<longdescription lang="en">
- A perl/Curses front end for Taskwarrior (<pkg>app-misc/task</pkg>) that
- provides a fullscreen terminal window with modes and commands
- modeled after the vi editor.
-</longdescription>
+ <maintainer type="person">
+ <email>mattst88@gentoo.org</email>
+ <name>Matt Turner</name>
+ </maintainer>
<upstream>
- <remote-id type="github">scottkosty/vit</remote-id>
+ <remote-id type="github">vit-project/vit</remote-id>
+ <remote-id type="pypi">vit</remote-id>
</upstream>
</pkgmetadata>
diff --git a/app-misc/vit/vit-1.3.ebuild b/app-misc/vit/vit-1.3.ebuild
deleted file mode 100644
index 39987374585f..000000000000
--- a/app-misc/vit/vit-1.3.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Perl/Curses front-end for Taskwarrior (app-misc/task)"
-HOMEPAGE="https://github.com/scottkosty/vit"
-SRC_URI="https://github.com/scottkosty/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-DEPEND="
- app-misc/task
- dev-lang/perl
- dev-perl/Curses"
-RDEPEND="${DEPEND}"
-
-RESTRICT="test" # missing the extra .makefile for extra targets (like test)
diff --git a/app-misc/vit/vit-2.3.2.ebuild b/app-misc/vit/vit-2.3.2.ebuild
new file mode 100644
index 000000000000..d55605c797ec
--- /dev/null
+++ b/app-misc/vit/vit-2.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=yes
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A lightweight, fast, curses-based front end to Taskwarrior"
+HOMEPAGE="
+ https://github.com/vit-project/vit
+ https://pypi.org/project/vit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-misc/task
+ $(python_gen_cond_dep '
+ >=dev-python/tasklib-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/urwid-2.1.2[${PYTHON_USEDEP}]
+ ')
+"
+
+distutils_enable_tests pytest