summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/screen/files/screen-4.3.1-bool_visual_bell.patch11
-rw-r--r--app-misc/screen/screen-9999.ebuild3
2 files changed, 14 insertions, 0 deletions
diff --git a/app-misc/screen/files/screen-4.3.1-bool_visual_bell.patch b/app-misc/screen/files/screen-4.3.1-bool_visual_bell.patch
new file mode 100644
index 000000000000..e316a62b2a49
--- /dev/null
+++ b/app-misc/screen/files/screen-4.3.1-bool_visual_bell.patch
@@ -0,0 +1,11 @@
+--- a/src/telnet.c
++++ b/src/telnet.c
+@@ -41,7 +41,7 @@
+
+ extern Window *fore;
+ extern Layer *flayer;
+-extern int visual_bell;
++extern bool visual_bell;
+ extern char screenterm[];
+ extern int af;
+
diff --git a/app-misc/screen/screen-9999.ebuild b/app-misc/screen/screen-9999.ebuild
index 3038ad6bd944..9118c6f787a8 100644
--- a/app-misc/screen/screen-9999.ebuild
+++ b/app-misc/screen/screen-9999.ebuild
@@ -36,6 +36,9 @@ src_prepare() {
# Don't use utempter even if it is found on the system
epatch "${FILESDIR}"/${PN}-4.3.0-no-utempter.patch
+ # visual_bell is no longer an int
+ epatch "${FILESDIR}"/${PN}-4.3.1-bool_visual_bell.patch
+
# sched.h is a system header and causes problems with some C libraries
mv sched.h _sched.h || die
sed -i '/include/ s:sched.h:_sched.h:' screen.h || die