summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/calcurse/calcurse-4.5.0.ebuild')
-rw-r--r--app-office/calcurse/calcurse-4.5.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-office/calcurse/calcurse-4.5.0.ebuild b/app-office/calcurse/calcurse-4.5.0.ebuild
new file mode 100644
index 000000000000..46600edc61fb
--- /dev/null
+++ b/app-office/calcurse/calcurse-4.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools eutils multilib-minimal
+
+DESCRIPTION="a text-based calendar and scheduling application"
+HOMEPAGE="https://calcurse.org/"
+SRC_URI="https://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/httplib2
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-text/asciidoc )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.1-tinfo.patch
+)
+
+# Most tests fail.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}
+
+src_compile() {
+ multilib-minimal_src_compile
+}
+
+src_install() {
+ multilib-minimal_src_install
+}