summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/geierlein/geierlein-0.9.12.ebuild')
-rw-r--r--app-office/geierlein/geierlein-0.9.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-office/geierlein/geierlein-0.9.12.ebuild b/app-office/geierlein/geierlein-0.9.12.ebuild
new file mode 100644
index 000000000000..782e682a6819
--- /dev/null
+++ b/app-office/geierlein/geierlein-0.9.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Submit tax forms (Umsatzsteuervoranmeldung) to German ELSTER"
+HOMEPAGE="https://stesie.github.com/geierlein/"
+SRC_URI="https://github.com/stesie/geierlein/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="|| ( www-client/firefox www-client/firefox-bin )"
+DEPEND=""
+
+# needs nodejs and a couple of modules we don't have packaged
+RESTRICT="test"
+
+src_compile() {
+ emake prefix=/usr
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix=/usr \
+ install || die
+ dodoc README.md
+}