summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/libreoffice/files/libreoffice-5.1.4.2-gcc6.patch')
-rw-r--r--app-office/libreoffice/files/libreoffice-5.1.4.2-gcc6.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-5.1.4.2-gcc6.patch b/app-office/libreoffice/files/libreoffice-5.1.4.2-gcc6.patch
new file mode 100644
index 000000000000..9e7ee7376813
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.1.4.2-gcc6.patch
@@ -0,0 +1,40 @@
+From 91fcc0032c2d0d343b914dfe3bea0b0bf1589e91 Mon Sep 17 00:00:00 2001
+From: Rene Engelhard <rene@debian.org>
+Date: Tue, 24 May 2016 16:35:57 +0200
+Subject: [PATCH] KDE4 cflags no /usr/include usage to fix build failure with
+ gcc6
+
+Change-Id: I53106b9ebfa7cc5c7b6c6d6f3bb3a4e5f2261f4f
+---
+ configure.ac | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 091abb4..86cc7b6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -11117,6 +11117,7 @@ the root of your Qt installation by exporting QT4DIR before running "configure".
+ if test "x$kde_incdir" = "xno"; then
+ AC_MSG_ERROR([KDE4 headers not found. Please specify the root of your KDE4 installation by exporting KDE4DIR before running "configure".])
+ fi
++ if test "$kde_incdir" = "/usr/include"; then kde_incdir=; fi
+
+ dnl Check for KDE4 libraries
+ AC_MSG_CHECKING([for KDE4 libraries])
+@@ -11134,7 +11135,12 @@ the root of your Qt installation by exporting QT4DIR before running "configure".
+ fi
+
+ PKG_CHECK_MODULES([QT4],[QtNetwork QtGui])
+- KDE4_CFLAGS="-I$kde_incdir $QT4_CFLAGS -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT"
++ if ! test -z "$kde_incdir"; then
++ KDE4_CFLAGS="-I$kde_incdir $QT4_CFLAGS -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT"
++ else
++ KDE4_CFLAGS="$QT4_CFLAGS -DQT_CLEAN_NAMESPACE -DQT_THREAD_SUPPORT"
++ fi
++
+ KDE4_LIBS="-L$kde_libdir -lkio -lkfile -lkdeui -lkdecore -L$qt_lib_dir $QT4_LIBS"
+ KDE4_CFLAGS=$(printf '%s' "$KDE4_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+ FilterLibs "$KDE4_LIBS"
+--
+2.9.0
+