summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/moneyguru/moneyguru-2.13.1-r2.ebuild (renamed from app-office/moneyguru/moneyguru-2.13.1-r1.ebuild)8
-rw-r--r--app-office/moneyguru/moneyguru-3.0.1-r2.ebuild (renamed from app-office/moneyguru/moneyguru-3.0.1-r1.ebuild)8
2 files changed, 12 insertions, 4 deletions
diff --git a/app-office/moneyguru/moneyguru-2.13.1-r1.ebuild b/app-office/moneyguru/moneyguru-2.13.1-r2.ebuild
index 5e3aaab58e12..31987d2240e4 100644
--- a/app-office/moneyguru/moneyguru-2.13.1-r1.ebuild
+++ b/app-office/moneyguru/moneyguru-2.13.1-r2.ebuild
@@ -21,11 +21,15 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
dev-db/sqlite:3
dev-libs/glib:2
- dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,widgets,printsupport]
+ ')
dev-qt/qttranslations"
DEPEND="${RDEPEND}
test? (
- <dev-python/pytest-4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/pytest-4[${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/cunit
)"
diff --git a/app-office/moneyguru/moneyguru-3.0.1-r1.ebuild b/app-office/moneyguru/moneyguru-3.0.1-r2.ebuild
index db78b348715e..ba927b91e60b 100644
--- a/app-office/moneyguru/moneyguru-3.0.1-r1.ebuild
+++ b/app-office/moneyguru/moneyguru-3.0.1-r2.ebuild
@@ -21,11 +21,15 @@ REQUIRED_USE=${PYTHON_REQUIRED_USE}
RDEPEND="${PYTHON_DEPS}
dev-db/sqlite:3
dev-libs/glib:2
- dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},gui,widgets,printsupport]
+ ')
dev-qt/qttranslations"
DEPEND="${RDEPEND}
test? (
- dev-python/pytest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ ')
dev-util/cunit
)"