summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/impressive/impressive-0.10.5.ebuild1
-rw-r--r--app-office/impressive/impressive-0.11.0b.ebuild6
2 files changed, 7 insertions, 0 deletions
diff --git a/app-office/impressive/impressive-0.10.5.ebuild b/app-office/impressive/impressive-0.10.5.ebuild
index f72ffa52819c..56345d19a079 100644
--- a/app-office/impressive/impressive-0.10.5.ebuild
+++ b/app-office/impressive/impressive-0.10.5.ebuild
@@ -21,6 +21,7 @@ IUSE=""
DEPEND=""
RDEPEND="${PYTHON_DEPS}
+ !>=dev-python/pillow-3.0.0
app-text/pdftk
virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/pygame[${PYTHON_USEDEP}]
diff --git a/app-office/impressive/impressive-0.11.0b.ebuild b/app-office/impressive/impressive-0.11.0b.ebuild
index 0f79ef3f6ae8..e312f17a39b2 100644
--- a/app-office/impressive/impressive-0.11.0b.ebuild
+++ b/app-office/impressive/impressive-0.11.0b.ebuild
@@ -35,6 +35,12 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S=${WORKDIR}/${MY_PN}-${PV}
+src_preparep() {
+ sed \
+ -e 's:tostring:tobytes:g' \
+ -i impressive.py || die
+}
+
src_install() {
python_foreach_impl python_doscript ${PN}.py