summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-officeext/texmaths')
-rw-r--r--app-officeext/texmaths/Manifest2
-rw-r--r--app-officeext/texmaths/metadata.xml8
-rw-r--r--app-officeext/texmaths/texmaths-0.37-r1.ebuild28
-rw-r--r--app-officeext/texmaths/texmaths-0.41.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/app-officeext/texmaths/Manifest b/app-officeext/texmaths/Manifest
new file mode 100644
index 000000000000..bb27eacdc497
--- /dev/null
+++ b/app-officeext/texmaths/Manifest
@@ -0,0 +1,2 @@
+DIST TexMaths-0.37.oxt 94750 SHA256 43baf8c6b83c8f7416817225d30fa025e7c953dc109217069147e0e15c1ab1b4 SHA512 c422dc4e207e614e42ac11fdf0fb3670f0e1778ff32ca242cd192737780c630efef1384a32d4304dc46fdad0f5062b23b3132b0f516e594e9696b2001c62302c WHIRLPOOL 9ea7dc6b388c962e63d5c19109b9d10bbc224dbdd6ab26b727c75583f78fb1633f889cc1ef56b80196bb9e3c3182f1e14fe71bce9b27a901fccebfb5e07c1f8b
+DIST TexMaths-0.41.oxt 151517 SHA256 dbf516cd59a731a8ee88bb18e8d278d8a1a36df321c6394672439f5621c23efa SHA512 32497367b1198cb9756bb253479c53ceaa9cbc40db3ed3bcf4c0b0cd24b8ad2cca1fdf8d1e7916827dfc1f4af8d615f4f7f9041e8a0b88a4d7cb76d345096bf3 WHIRLPOOL dc6825b66707135dc062d9727b9e78838004392a2805cf013ea0ecf58fd679ecafcaa7ad06ec2ed08d746c98a1e056bf7ea13e1373e54ffd07c90cedee0a2ca7
diff --git a/app-officeext/texmaths/metadata.xml b/app-officeext/texmaths/metadata.xml
new file mode 100644
index 000000000000..cd8b3e411f9b
--- /dev/null
+++ b/app-officeext/texmaths/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <upstream>
+ <remote-id type="sourceforge">texmaths</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-officeext/texmaths/texmaths-0.37-r1.ebuild b/app-officeext/texmaths/texmaths-0.37-r1.ebuild
new file mode 100644
index 000000000000..a5ff66ce844e
--- /dev/null
+++ b/app-officeext/texmaths/texmaths-0.37-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="TexMaths-${PV}"
+
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="LaTeX Equation Editor for LibreOffice"
+HOMEPAGE="http://roland65.free.fr/texmaths/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.oxt"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-text/dvisvgm
+ virtual/tex-base
+"
diff --git a/app-officeext/texmaths/texmaths-0.41.ebuild b/app-officeext/texmaths/texmaths-0.41.ebuild
new file mode 100644
index 000000000000..b48450c0964a
--- /dev/null
+++ b/app-officeext/texmaths/texmaths-0.41.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P="TexMaths-${PV}"
+
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="LaTeX Equation Editor for LibreOffice"
+HOMEPAGE="http://roland65.free.fr/texmaths/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.oxt"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-text/dvisvgm
+ virtual/tex-base
+"