summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild')
-rw-r--r--app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild b/app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild
new file mode 100644
index 000000000000..aff499910837
--- /dev/null
+++ b/app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A tool (and library) for decompressing data compressed with PKWARE Data Compression Library"
+HOMEPAGE="https://github.com/twogood/dynamite http://sourceforge.net/projects/synce/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-bootstrap.patch
+ ./bootstrap
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}