summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/g-cpan/g-cpan-0.16.6.ebuild')
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.6.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-portage/g-cpan/g-cpan-0.16.6.ebuild b/app-portage/g-cpan/g-cpan-0.16.6.ebuild
deleted file mode 100644
index ea01a673c5c9..000000000000
--- a/app-portage/g-cpan/g-cpan-0.16.6.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit perl-module
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/gentoo-perl/g-cpan.git"
- inherit git-r3
- SRC_URI=""
-else
- SRC_URI="https://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-fi
-
-DESCRIPTION="g-cpan: generate and install CPAN modules using portage"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Perl/g-cpan"
-
-LICENSE="|| ( Artistic GPL-2 )"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-lang/perl
- >=dev-perl/YAML-0.60
- >=dev-perl/Shell-EnvImporter-1.70.0-r2
- dev-perl/Log-Agent"
-RDEPEND="${DEPEND}"
-
-src_install() {
- perl-module_src_install
- diropts "-m0755"
- dodir "/var/tmp/g-cpan"
- dodir "/var/log/g-cpan"
- keepdir "/var/log/g-cpan"
-}
-
-pkg_postinst() {
- elog "You may wish to adjust the permissions on /var/tmp/g-cpan"
- elog "if you have users besides root expecting to use g-cpan."
- elog "Please note that some CPAN packages need additional manual"
- elog "parameters or tweaking, due to bugs in their build systems."
-}