summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/bash-5.2_rc1.ebuild')
-rw-r--r--app-shells/bash/bash-5.2_rc1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-shells/bash/bash-5.2_rc1.ebuild b/app-shells/bash/bash-5.2_rc1.ebuild
index af272883e190..30812eac26e8 100644
--- a/app-shells/bash/bash-5.2_rc1.ebuild
+++ b/app-shells/bash/bash-5.2_rc1.ebuild
@@ -75,8 +75,10 @@ IUSE="afs bashlogger examples mem-scramble +net nls plugins +readline"
DEPEND="
>=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )
- readline? ( >=sys-libs/readline-${READLINE_VER}:0= )
"
+if is_release ; then
+ DEPEND+=" readline? ( >=sys-libs/readline-${READLINE_VER}:= )"
+fi
RDEPEND="
${DEPEND}
"
@@ -86,6 +88,9 @@ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-chetramey )"
S="${WORKDIR}/${MY_P}"
+# EAPI 8 tries to append it but it doesn't exist here
+QA_CONFIGURE_OPTIONS+="--disable-static"
+
PATCHES=(
#"${WORKDIR}"/${PN}-${GENTOO_PATCH_VER}/