summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/dash/dash-0.5.7.4.ebuild')
-rw-r--r--app-shells/dash/dash-0.5.7.4.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-shells/dash/dash-0.5.7.4.ebuild b/app-shells/dash/dash-0.5.7.4.ebuild
deleted file mode 100644
index 5a6d473eb7c3..000000000000
--- a/app-shells/dash/dash-0.5.7.4.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-inherit autotools eutils flag-o-matic toolchain-funcs
-
-DEB_PV=${PV%.*}
-DEB_PATCH=${PV##*.}
-DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
-MY_P="${PN}-${DEB_PV}"
-
-DESCRIPTION="DASH is a direct descendant of the NetBSD version of ash (the Almquist SHell) and is POSIX compliant"
-HOMEPAGE="http://gondor.apana.org.au/~herbert/dash/"
-SRC_URI="http://gondor.apana.org.au/~herbert/dash/files/${PN}-${DEB_PV}.tar.gz
- mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="libedit static"
-
-RDEPEND="!static? ( libedit? ( dev-libs/libedit ) )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- libedit? ( static? ( dev-libs/libedit[static-libs] ) )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${WORKDIR}"/${DEB_PF}.diff
- epatch */debian/diff/*
- epatch "${FILESDIR}"/${PN}-0.5.5.1-octal.patch #337329
-
- # Fix the invalid sort
- sed -i -e 's/LC_COLLATE=C/LC_ALL=C/g' src/mkbuiltins
-
- # Use pkg-config for libedit linkage
- sed -i "/LIBS/s:-ledit:\`$(tc-getPKG_CONFIG) --libs libedit $(usex static --static '')\`:" configure.ac
-
- # May as well, as the debian patches force this anyway
- eautoreconf
-}
-
-src_configure() {
- use static && append-ldflags -static
- # Do not pass --enable-glob due to #443552.
- econf \
- --bindir="${EPREFIX}"/bin \
- --enable-fnmatch \
- $(use_with libedit)
-}
-
-src_install() {
- default
- dodoc */debian/changelog
-}