summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/fzf/files/fzf-0.21.0-makefile.patch')
-rw-r--r--app-shells/fzf/files/fzf-0.21.0-makefile.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-shells/fzf/files/fzf-0.21.0-makefile.patch b/app-shells/fzf/files/fzf-0.21.0-makefile.patch
new file mode 100644
index 000000000000..24653a7b8219
--- /dev/null
+++ b/app-shells/fzf/files/fzf-0.21.0-makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 037b19b..60283d0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -6,7 +6,7 @@ ROOT_DIR := $(shell dirname $(MAKEFILE))
+ SOURCES := $(wildcard *.go src/*.go src/*/*.go) $(MAKEFILE)
+
+ REVISION := $(shell git log -n 1 --pretty=format:%h -- $(SOURCES))
+-BUILD_FLAGS := -a -ldflags "-X main.revision=$(REVISION) -w -extldflags=$(LDFLAGS)" -tags "$(TAGS)"
++BUILD_FLAGS := -a -ldflags "-X main.revision=$(REVISION) -w '-extldflags=$(LDFLAGS)'" -tags "$(TAGS)"
+
+ BINARY32 := fzf-$(GOOS)_386
+ BINARY64 := fzf-$(GOOS)_amd64