summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild')
-rw-r--r--app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
new file mode 100644
index 000000000000..fb1666185293
--- /dev/null
+++ b/app-shells/gentoo-zsh-completions/gentoo-zsh-completions-99999999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radhermit/gentoo-zsh-completions.git"
+else
+ SRC_URI="https://github.com/radhermit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+fi
+
+DESCRIPTION="Gentoo specific zsh completion support (includes emerge and ebuild commands)"
+HOMEPAGE="https://github.com/radhermit/gentoo-zsh-completions"
+
+LICENSE="ZSH"
+SLOT="0"
+
+RDEPEND=">=app-shells/zsh-4.3.5"
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/_*
+
+ dodoc AUTHORS
+}