summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/bibclean')
-rw-r--r--app-text/bibclean/Manifest3
-rw-r--r--app-text/bibclean/bibclean-2.17.ebuild26
-rw-r--r--app-text/bibclean/bibclean-3.04.ebuild25
-rw-r--r--app-text/bibclean/bibclean-3.06.ebuild21
4 files changed, 22 insertions, 53 deletions
diff --git a/app-text/bibclean/Manifest b/app-text/bibclean/Manifest
index 03fc45bbd3fd..02c7c5dc9e01 100644
--- a/app-text/bibclean/Manifest
+++ b/app-text/bibclean/Manifest
@@ -1,2 +1 @@
-DIST bibclean-2.17.tar.bz2 2253830 BLAKE2B 4d707f8d07f04c45c44fbea2b12bfffc7636cef2a847d90e62f339cb8fdadbb416cd89c2ba1cb04b0fc9c736dd7ca8480a2cbd4dab9c27b1f6804ddd18fc5419 SHA512 5f0d6b315ecc98c47f48c1e5fe7bcbd374cf97dec5cc97ce4438300a7419e6b2f1efae313efdf9d21211e9cd658c1f4bac10aa3b0d55dfa8a5783d982b1dde0f
-DIST bibclean-3.04.tar.gz 2712015 BLAKE2B 80d2fccb3b453dfda935bedd73ea2173b6ba1416c425a094c6ca915e86a886fe269b2f0e392274775228b03578ccf19da03291ed644f589edec1692120456a99 SHA512 7cdd22d07f627944d90e04ca73c3c82529e2fa9a011469f8d5b418f7651332b4e8c29aceda32b966bb1778151505d7f135ead6a12db8975ff46f650c4c43b4f3
+DIST bibclean-3.06.tar.xz 1697732 BLAKE2B c1d9623588e892360eb98e753b44cb54e0eb65d3e3d46a04463c0c3183beacb58fd07542ba06d00eb754061b45ed195a82b90b2843b6ba456c7ba09856090474 SHA512 b167243415f010d7597ffdf52c5bb71de3585f70443c3a04f762a633b2bc276c7aef50e16159c32d8765924be2781b1e60a111305a17c2f42b68ed5216b2e31b
diff --git a/app-text/bibclean/bibclean-2.17.ebuild b/app-text/bibclean/bibclean-2.17.ebuild
deleted file mode 100644
index fc8d456dd364..000000000000
--- a/app-text/bibclean/bibclean-2.17.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="BibTeX bibliography prettyprinter and syntax checker"
-SRC_URI="http://www.math.utah.edu/pub/bibclean/${P}.tar.bz2"
-HOMEPAGE="http://www.math.utah.edu/pub/bibclean/"
-
-# http://packages.debian.org/changelogs/pool/main/b/bibclean/bibclean_2.11.4-5/bibclean.copyright
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-SLOT="0"
-
-src_compile() {
- emake -j1 LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin bibclean
- newman bibclean.man bibclean.1
-}
diff --git a/app-text/bibclean/bibclean-3.04.ebuild b/app-text/bibclean/bibclean-3.04.ebuild
deleted file mode 100644
index d7f1a69fa5e6..000000000000
--- a/app-text/bibclean/bibclean-3.04.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="BibTeX bibliography prettyprinter and syntax checker"
-SRC_URI="ftp://ftp.math.utah.edu/pub/bibclean/${P}.tar.gz"
-HOMEPAGE="http://www.math.utah.edu/pub/bibclean/"
-
-# http://packages.debian.org/changelogs/pool/main/b/bibclean/bibclean_2.11.4-5/bibclean.copyright
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-SLOT="0"
-
-src_compile() {
- emake LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- dobin bibclean
- newman bibclean.man bibclean.1
-}
diff --git a/app-text/bibclean/bibclean-3.06.ebuild b/app-text/bibclean/bibclean-3.06.ebuild
new file mode 100644
index 000000000000..25ac2ac350fc
--- /dev/null
+++ b/app-text/bibclean/bibclean-3.06.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="BibTeX bibliography prettyprinter and syntax checker"
+HOMEPAGE="https://ftp.math.utah.edu/pub/bibclean/"
+SRC_URI="https://ftp.math.utah.edu/pub/bibclean/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin bibclean
+ newman bibclean.man bibclean.1
+}