summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/code2html/code2html-0.9.1-r1.ebuild')
-rw-r--r--app-text/code2html/code2html-0.9.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/code2html/code2html-0.9.1-r1.ebuild b/app-text/code2html/code2html-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..696499147eda
--- /dev/null
+++ b/app-text/code2html/code2html-0.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils prefix
+
+DESCRIPTION="Converts source files to colored HTML output"
+HOMEPAGE="http://www.palfrader.org/code2html/"
+SRC_URI="http://www.palfrader.org/code2html/all/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo_patches.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5"
+
+src_prepare() {
+ # Be consistent in color codes (bug #119406)
+ epatch "${WORKDIR}"/${P}-lowercase_color_codes.patch
+
+ # Improved C++ support (bug #133159)
+ epatch "${WORKDIR}"/${P}-cpp_keywords.patch
+
+ # Improved Ada support (bug #133176)
+ epatch "${WORKDIR}"/${P}-ada_identifiers.patch
+
+ # For prefix paths
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify code2html
+}
+
+src_install() {
+ dobin code2html
+ dodoc ChangeLog CREDITS README
+ doman code2html.1
+}