summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libwpd/libwpd-0.10.2.ebuild')
-rw-r--r--app-text/libwpd/libwpd-0.10.2.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/app-text/libwpd/libwpd-0.10.2.ebuild b/app-text/libwpd/libwpd-0.10.2.ebuild
deleted file mode 100644
index 48e245627e30..000000000000
--- a/app-text/libwpd/libwpd-0.10.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit alternatives
-
-DESCRIPTION="WordPerfect Document import/export library"
-HOMEPAGE="http://libwpd.sf.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
-
-LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
-SLOT="0.10"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 x86 ~x86-fbsd"
-IUSE="doc +tools"
-
-RDEPEND="dev-libs/librevenge"
-DEPEND="${RDEPEND}
- dev-libs/boost
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-
-src_configure() {
- econf \
- --disable-static \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable tools) \
- --program-suffix=-${SLOT}
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- if use tools; then
- alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
- alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
- alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
- fi
-}
-
-pkg_postrm() {
- if use tools; then
- alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
- alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
- alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
- fi
-}