summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/passivetex/passivetex-1.25-r2.ebuild')
-rw-r--r--app-text/passivetex/passivetex-1.25-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/passivetex/passivetex-1.25-r2.ebuild b/app-text/passivetex/passivetex-1.25-r2.ebuild
new file mode 100644
index 000000000000..910eec2007e3
--- /dev/null
+++ b/app-text/passivetex/passivetex-1.25-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package
+
+DESCRIPTION="A namespace-aware XML parser written in Tex"
+HOMEPAGE="http://www.tei-c.org.uk/Software/passivetex/"
+# Taken from: http://www.tei-c.org.uk/Software/passivetex/${PN}.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+S=${WORKDIR}/${PN}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+RDEPEND="virtual/latex-base
+ dev-texlive/texlive-formatsextra"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ insinto ${TEXMF}/tex/xmltex/passivetex
+ doins *.sty *.xmt
+
+ dodoc README.passivetex index.{html,xml}
+}