summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/pdf2htmlEX')
-rw-r--r--app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild20
1 files changed, 18 insertions, 2 deletions
diff --git a/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild b/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild
index d02dd44ec396..5b00b84e7746 100644
--- a/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild
+++ b/app-text/pdf2htmlEX/pdf2htmlEX-0.14.6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils toolchain-funcs flag-o-matic
DESCRIPTION="A precise PDF to HTML converter"
HOMEPAGE="http://coolwanglu.github.io/pdf2htmlEX/"
@@ -14,7 +14,7 @@ SRC_URI="
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
IUSE=""
@@ -30,3 +30,19 @@ RDEPEND="${CDEPEND}
DEPEND="${CDEPEND}
virtual/pkgconfig
"
+
+pkg_pretend() {
+ local ver=6.4.0
+ local msg="${P} needs at least GCC ${ver} set to compile."
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! version_is_at_least ${ver} $(gcc-fullversion); then
+ die ${msg}
+ fi
+ fi
+}
+
+src_configure() {
+ append-cflags -no-pie
+ append-cxxflags -no-pie
+ cmake-utils_src_configure
+}