summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xapian-omega/xapian-omega-1.3.5.ebuild')
-rw-r--r--app-text/xapian-omega/xapian-omega-1.3.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/xapian-omega/xapian-omega-1.3.5.ebuild b/app-text/xapian-omega/xapian-omega-1.3.5.ebuild
new file mode 100644
index 000000000000..3115790ae38e
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="http://www.xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/xapian:0/1.3.6
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ #move docs to /usr/share/doc/${PF}.
+ mv "${D}/usr/share/doc/xapian-omega" "${D}/usr/share/doc/${PF}" || die
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}