summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-0.1.6.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.6.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/app-text/zathura-cb/zathura-cb-0.1.6.ebuild b/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
deleted file mode 100644
index 8422c19f22a2..000000000000
--- a/app-text/zathura-cb/zathura-cb-0.1.6.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs readme.gentoo-r1
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
- EGIT_BRANCH="develop"
-else
- KEYWORDS="amd64 arm x86"
- SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-
-DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
-HOMEPAGE="https://pwmt.org/projects/zathura/"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=app-text/zathura-0.3.1
- dev-libs/glib:2=
- app-arch/libarchive:=
- x11-libs/cairo:=
- x11-libs/gdk-pixbuf:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- myzathuraconf=(
- CC="$(tc-getCC)"
- LD="$(tc-getLD)"
- VERBOSE=1
- DESTDIR="${D}"
- )
-}
-
-src_compile() {
- emake "${myzathuraconf[@]}"
-}
-
-src_install() {
- emake "${myzathuraconf[@]}" install
- dodoc AUTHORS
-
- FORCE_PRINT_ELOG=1
- local DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
- app-arch/unzip for additional file support."
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}