summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/editorconfig-vim')
-rw-r--r--app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild b/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild
index 4e2840e51deb..44e5e9b68b3c 100644
--- a/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild
+++ b/app-vim/editorconfig-vim/editorconfig-vim-0.3.3-r2.ebuild
@@ -4,19 +4,26 @@
EAPI=6
PYTHON_COMPAT=(python2_7 python3_4 python3_5 python3_6)
+
inherit python-r1 vim-plugin
DESCRIPTION="vim plugin: Support EditorConfig files "
HOMEPAGE="http://editorconfig.org/"
+SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
LICENSE="BSD-2"
KEYWORDS="~amd64 ~x86"
-SRC_URI="https://github.com/${PN%-vim}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="dev-python/editorconfig-core-py[${PYTHON_USEDEP}]
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/editorconfig-core-py[${PYTHON_USEDEP}]
|| (
- app-editors/vim[python,${PYTHON_USEDEP}]
- app-editors/gvim[python,${PYTHON_USEDEP}]
-)"
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )"
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${P}-python3.patch"