summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimpress/vimpress-3.2.0-r1.ebuild')
-rw-r--r--app-vim/vimpress/vimpress-3.2.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/vimpress/vimpress-3.2.0-r1.ebuild b/app-vim/vimpress/vimpress-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..e7e8ba8673dd
--- /dev/null
+++ b/app-vim/vimpress/vimpress-3.2.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: manage wordpress blogs from vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3510"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+ ')"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"