summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vim-jsonnet/Manifest1
-rw-r--r--app-vim/vim-jsonnet/metadata.xml11
-rw-r--r--app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild24
3 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/vim-jsonnet/Manifest b/app-vim/vim-jsonnet/Manifest
new file mode 100644
index 000000000000..95cd1e8fa862
--- /dev/null
+++ b/app-vim/vim-jsonnet/Manifest
@@ -0,0 +1 @@
+DIST vim-jsonnet-0_pre20190502.tar.gz 102599 BLAKE2B 14f9fd72e6791fbd78b3749f860115a9a63137f7dc5e2d1eabae45b777dcebd902c9fa100665e2447ad0d6c8cd4e117beefc2bf16efd98c3382c84a2ebdc3951 SHA512 cac7b41cdd1749eab575cfdd0e897b37f2c842b69ad4a62c355c231d8d93668ab2e9929893bea72697ca512bf40a7768019b28866643025505abc421fbea12ec
diff --git a/app-vim/vim-jsonnet/metadata.xml b/app-vim/vim-jsonnet/metadata.xml
new file mode 100644
index 000000000000..81356ad8ead3
--- /dev/null
+++ b/app-vim/vim-jsonnet/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/vim-jsonnet</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild b/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild
new file mode 100644
index 000000000000..df90ee8b9a49
--- /dev/null
+++ b/app-vim/vim-jsonnet/vim-jsonnet-0_pre20190502.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+COMMIT_HASH="824dcfe76568dba38135332fc4729e2b2c4d9b3a"
+
+DESCRIPTION="vim plugin: Filetype plugin for dev-lang/jsonnet"
+HOMEPAGE="https://github.com/google/vim-jsonnet"
+SRC_URI="https://github.com/google/vim-jsonnet/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/jsonnet"
+
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+src_prepare() {
+ default
+
+ rm -f LICENSE .gitignore || die
+}