summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/lightline/lightline-9999.ebuild22
-rw-r--r--app-vim/lightline/metadata.xml11
2 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/lightline/lightline-9999.ebuild b/app-vim/lightline/lightline-9999.ebuild
new file mode 100644
index 000000000000..e2c2c5f6ba4e
--- /dev/null
+++ b/app-vim/lightline/lightline-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/itchyny/lightline.vim/"
+else
+ SRC_URI="https://github.com/itchyny/${PN}.vim/archive/master.zip -> ${P}.zip"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: A light and configurable statusline/tabline"
+HOMEPAGE="https://github.com/itchyny/lightline.vim/"
+LICENSE="vim.org"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_compile() { :; }
diff --git a/app-vim/lightline/metadata.xml b/app-vim/lightline/metadata.xml
new file mode 100644
index 000000000000..6c8987e6f46f
--- /dev/null
+++ b/app-vim/lightline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>