summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/Manifest1
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20180821.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index e47c36acb7fe..aa018fa050b7 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -2,3 +2,4 @@ DIST gentoo-syntax-20160530.tar.gz 18950 BLAKE2B 0e769cb4d67ebf1b4299a1aa0dc1bc1
DIST gentoo-syntax-20170225.tar.gz 18939 BLAKE2B 7586b45791e74e69ad6e0607bc0a4d52eba4747a6c4d9933d43db1196ceb57ac6317279c9e86f77c71bdb7379828dd96fe6d63a2933a3660f1639faf1b6df5d5 SHA512 2c01577910eccd413b85c094dbd12bf8445e2f560be1fffc4a4c3130b32587f9c298d8442b5cf12bd7d2950ab8c9e5b95a72f2f41c42c6dc939ffa2c26fd71d5
DIST gentoo-syntax-20180814.tar.bz2 18337 BLAKE2B e2808ff4bab17378ac9a15270f32edb67c0a8f4a7e17757d9c128e186fe31add967c169aa9e62fd5fc95dfbadeab72e37c34a14a5452b80c0a1ceafd8bdec85a SHA512 a524a324e3bb1656b2dba9333e03bd130d3700791782d98fed57ea6065f398e4ad29f7980ad823940a44cd1f9f58244b8a908ef4aa3c82c0f7c46882005f358e
DIST gentoo-syntax-20180820.tar.bz2 18470 BLAKE2B dc536724cd8cf8547b54c7ecc1fc12364ee4542903627e7a3518b9583157d18645e62be519a5d0d0c50f36fe05dfdd19d6999ad049722519f4d6d5707274da44 SHA512 b07fd9b93796a775da0f0fedacbd09cdd30dc414abd05636e96cc0658d1bc12dc5b88cbe4475544f3c79b1a28dacab234cf3c463ddb90bd4e62bec8de4024a57
+DIST gentoo-syntax-20180821.tar.bz2 18361 BLAKE2B 4134fd0a3d75d86f3984f135021063b68588083f191efcb94d7b599460703d6eb501bad7de2aa0cc9cdc4447d73b83e4b36cee2acdd113e7d0a879e1e864e2fb SHA512 09c70ded667b489e03f02e0e72fca32f13a40501a5e319b387967e75f616c7f3dc44ceab3a46b776a509263f58668223eb85d51ba58ca3fbc48e4c05d7345dfc
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20180821.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20180821.ebuild
new file mode 100644
index 000000000000..badfc293470c
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20180821.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}