summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/mm-common/mm-common-1.0.2.ebuild')
-rw-r--r--dev-cpp/mm-common/mm-common-1.0.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-cpp/mm-common/mm-common-1.0.2.ebuild b/dev-cpp/mm-common/mm-common-1.0.2.ebuild
new file mode 100644
index 000000000000..39f6d7b82324
--- /dev/null
+++ b/dev-cpp/mm-common/mm-common-1.0.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson
+
+DESCRIPTION="Build infrastructure and utilities for GNOME C++ bindings"
+HOMEPAGE="https://www.gtkmm.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+src_prepare() {
+ default
+
+ # Include project version in docdir name
+ sed -i -e "s:^install_docdir.*:& + '-' + meson.project_version():" meson.build || die
+}