summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/rapidyaml/files/rapidyaml-0.3.0-no-download.patch')
-rw-r--r--dev-cpp/rapidyaml/files/rapidyaml-0.3.0-no-download.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/rapidyaml/files/rapidyaml-0.3.0-no-download.patch b/dev-cpp/rapidyaml/files/rapidyaml-0.3.0-no-download.patch
new file mode 100644
index 000000000000..97c4926cd9d2
--- /dev/null
+++ b/dev-cpp/rapidyaml/files/rapidyaml-0.3.0-no-download.patch
@@ -0,0 +1,23 @@
+--- a/ext/testbm.cmake
++++ b/ext/testbm.cmake
+@@ -1,4 +1,2 @@
+ # these are used both for testing and benchmarking
+-c4_require_subproject(c4fs REMOTE
+- GIT_REPOSITORY https://github.com/biojppm/c4fs
+- GIT_TAG master)
++c4_require_subproject(c4fs SUBDIRECTORY ext/c4fs)
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -103,10 +103,5 @@
+
+- c4_require_subproject(c4log REMOTE
+- GIT_REPOSITORY https://github.com/biojppm/c4log
+- GIT_TAG master)
++ c4_require_subproject(c4log SUBDIRECTORY ../ext/c4log)
+
+- set(tsdir ${ed}/yaml-test-suite)
+- c4_download_remote_proj(yaml-test-suite tsdir
+- GIT_REPOSITORY https://github.com/yaml/yaml-test-suite
+- GIT_TAG bcd49a2d4919c1b1ac3b9d6e5ebe6b140b5089e3)
++ set(tsdir ${CMAKE_SOURCE_DIR}/ext/yaml-test-suite)
+ set(suite_dir ${tsdir}/src)